Creates the Site Using PnP, but Hero Webpart causes Image thumbnail issue.

Nikhil 6 Reputation points
2021-08-25T17:11:41.493+00:00

Hi,

Created site using PnP provisioning, using below link,

https://learn.microsoft.com/en-us/sharepoint/dev/declarative-customization/site-design-pnp-provisioning

but when we published the template page from based site, all the thumbnail images removed for Hero webpart, not getting applied.

images are present under the SiteAssets, still unable to find the reference.

on console, we are getting the error,

{SPURL}/_api/v2.1/sites/{URL},{Uid data}/lists/{Uid}/items/{UID}/driveItem/thumbnails/0/{UID}/content?preferNoRedirect=true&prefer=extendCacheMaxAge&clientType=modernWebPart

{"error":{"code":"itemNotFound","message":"Item not found"}}

Can you please help us to resolved the query.

Thanks

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
2,243 questions
Microsoft Office Online Server
Microsoft Office Online Server
Microsoft on-premises server product that runs Office Online. Previously known as Office Web Apps Server.
590 questions
SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,793 questions
SharePoint Development
SharePoint Development
SharePoint: A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.Development: The process of researching, productizing, and refining new or existing technologies.
2,701 questions
0 comments No comments
{count} vote