Using VS2019 with WSL for an existing project (not new one)

Umer Nalla 1 Reputation point
2021-08-27T11:25:07.71+00:00

I have Microsoft Visual Studio Professional 2019 Version 16.11.2 with the Linux Development for C++ option installed as well.
I have also checked under 'Individual Components' in the Installer and I can see 'C++ Cmake tools for Linux' and 'C++ for Linux Development' as installed.

The problem:
If I open a local Windows file system directory containing a CMakeLists.txt file, the Solution Explorer is populated and I see CMake related output in the Output window.

However, if I try to open a similar folder from a WSL file system folder, nothing happens - Visual Studio just sits there - no output and empty Solution Explorer.

I have tried both the File->Open Folder and File->Open Cmake options - no difference.

Any ideas where things are going wrong?

For reference, the existing project I am trying to open is https://github.com/Refinitiv/Real-Time-SDK/tree/master/Cpp-C
I have tried the subfolders too - which have individual CMakeLists.txt - no difference.

C++
C++
A high-level, general-purpose programming language, created as an extension of the C programming language, that has object-oriented, generic, and functional features in addition to facilities for low-level memory manipulation.
3,590 questions
{count} votes