This submission failed with error code(s) 1201

Ivan Ičin 111 Reputation points
2021-08-27T17:25:37.503+00:00

I am receiving this message for no apparent reason.

To explain in more details, my package contains of one UWP app and one very small Win32 app. When I submit the full package to the Microsoft Store I am getting the error above. It also appears in the package flight if I submit the full package. However if I submit just the UWP app package it passes the package flight.

So the problem appears to be caused by the Win32 app or by the package project if it is possible at all. But those have been unchanged for years and are that simple that I really cannot see any possibility for the error.

So the problem appears to be a server side bug and I have no idea what to do about it. I have been suggested to write to reportap@microsoft.com . But they don't provide any technical answers, they have never confirmed or denied that there is a bug on the server upon my persistent questions to get that answer and now they don't even reply to emails anymore.

Aside from something we all have learned the hard way - it is better to give up on Windows developing sooner rather than later - does anyone have any suggestion?

Just a side comment, this comes at a point when Microsoft will allow any kind of unsafe apps into the Store. At the same time this same company tries to tighten the security rules for existing apps and introduces the bugs that make the app updates impossible. You have to be naturally gifted to achieve this level of incompetence, that is not for ordinary people.

Universal Windows Platform (UWP)
Microsoft Partner Center
Microsoft Partner Center
A Microsoft website for partners that provides access to product support, a partner community, and other partner services.
904 questions
{count} votes

Accepted answer
  1. Ivan Ičin 111 Reputation points
    2021-09-01T17:45:38.867+00:00

    Hello, I have found the cause of the problem. Actually there are two causes:

    1. I have proved that there is a bug on the Microsoft side and I was constantly denied by Microsoft's support
    2. If I remove ARM64 architecture I can submit the app. So it seems that having UWP + Win32 + ARM64 in some way causes the build server to break in pre-processing.

    I am really not sure why no one wanted to look at this when it was obviously a server side error. I have lost whole month on this.

    At the moment I will submit only x64 package as it works and hopefully someone can make a fix based on this.

    1 person found this answer helpful.
    0 comments No comments

3 additional answers

Sort by: Most helpful
  1. Ruofan Zhu 1 Reputation point
    2021-10-03T16:52:04.95+00:00

    Please check the issue in here: https://github.com/microsoft/microsoft-ui-xaml/issues/5768

    Microsoft Support always reply me with “Template“. So I could not get the log and details from the team.

    I could provide source code or upload package and I found this issue related to WinUI 2.6.X or 2.7.X. Downgrade to WinUI 2.5.0 and we could pass the validation of MSStore.


  2. Ivan Ičin 111 Reputation points
    2021-10-04T18:16:00.197+00:00

    Thanks for the heads-up. I wasn't fully aware of all of the causes of the problem, but for me it is easier to drop support for ARM64 than to downgrade nuget.

    0 comments No comments

  3. Sree Sundaram 1 Reputation point
    2021-10-05T15:35:15.64+00:00

    The whole submission process in the Windows store is a crapshoot. Other than getting a cryptic message saying that it failed due to error code 1201, I am not getting any additional information. I followed the advice in this post and submitted an X64 package. It worked for my first version. In the next update, I mistakenly created a bundle for all three x86, x64 and ARM and miraculously it worked. Now in my third update, nothing seems to work. I tried the full bundle (x86, x64, ARM), I tried Win only (x86, x64) and Win32 (x64 only). For x64, I tried creating with and without a bundle (I am not sure it makes a difference if it is only one platform).

    Looking for some serious help here.

    Sree

    0 comments No comments