Restore Resource list is empty for Azure Cosmos DB that has Continuous Backup policy enabled (In Preview)

Mahesh Bakali 11 Reputation points
2021-08-28T22:29:45.37+00:00

I enabled Continuous Backup policy on my existing Azure Cosmos DB account on 4-Aug-2021 and tested some Point In Time Restore feature. It was all fine until 28-Aug-2021 where I started getting error when I tried restoring the account. The error says "No resources in account to restore for the given restore point". The same issue happens when I try to restore an individual database/container (there are no resources listed in the drop down). I can see "Azure Cosmos DB: Continuous backup with point in time restore now in general availability" on 18-Aug-2021 on Azure Updates.

Can you please help me with this?

Azure Cosmos DB
Azure Cosmos DB
An Azure NoSQL database service for app development.
1,504 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Oury Ba-MSFT 17,156 Reputation points Microsoft Employee
    2021-09-01T20:07:52.637+00:00

    @Mahesh Bakali Continuous back up policy for point in time restore is supported for Azure Cosmos DB API. Are there any resources in the Cosmos dB account you have created recently. I tried to repro the issue from my end by creating a new Cosmos DB SQL API and enabled continuous back . I selected entire account and the resource I created in my Cosmos DB account. As you can see below.

    128355-image.png

    Could you please check if the resources were not deleted.
    and also check if you are seeing any message at the bottom of the page where you are creating the point in time restore. Please do not hesitate to reach out if you need additional clarification

    Regards,
    Oury


  2. Oury Ba-MSFT 17,156 Reputation points Microsoft Employee
    2021-09-02T14:41:25.16+00:00

    @Mahesh Bakali Thank you for providing the information. Could you please select click on the click here button and select the database name. Then select the option selected database/containers instead of entire account.
    Please follow the same step below and let me know if you are still facing issues
    Please also note that the error message indicates that if there is no resource in the cosmos DB account , it won't work.

    1. 128649-image.png
    2. 128763-image.png

    Regards,
    Oury