configuration manager 2103 fatal msi error - mp.msi could not be installed

Kudzanayi Sabeta 21 Reputation points
2021-08-31T12:07:04.677+00:00

I am having a challenge after installing configuration manager the management point is failing to install and if I check both logs (mpsetuplog and mpmsi.log) there is a fatal MSI error - mp.msi could not be installed, check the logs below
mpMSI.log
Property(S): ProductToBeRegistered = 1
Property(S): CCMHTTPSPORT = 443
MSI (s) (C0:C4) [13:34:37:711]: Note: 1: 1708
MSI (s) (C0:C4) [13:34:37:711]: Product: ConfigMgr Management Point -- Installation operation failed.
MSI (s) (C0:C4) [13:34:37:712]: Windows Installer installed the product. Product Name: ConfigMgr Management Point. Product Version: 5.00.9049.1000. Product Language: 1033. Manufacturer: Microsoft Corporation. Installation success or error status: 1603.
MSI (s) (C0:C4) [13:34:37:722]: Deferring clean up of packages/files, if any exist
MSI (s) (C0:C4) [13:34:37:722]: MainEngineThread is returning 1603
MSI (s) (C0:7C) [13:34:37:725]: RESTART MANAGER: Session closed.
MSI (s) (C0:7C) [13:34:37:725]: No System Restore sequence number for this installation.
=== Logging stopped: 8/31/2021 13:34:37 ===
MSI (s) (C0:7C) [13:34:37:726]: User policy value 'DisableRollback' is 0
MSI (s) (C0:7C) [13:34:37:726]: Machine policy value 'DisableRollback' is 0
MSI (s) (C0:7C) [13:34:37:726]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (C0:7C) [13:34:37:726]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (C0:7C) [13:34:37:726]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (C0:7C) [13:34:37:726]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (s) (C0:7C) [13:34:37:727]: Destroying RemoteAPI object.
MSI (s) (C0:F8) [13:34:37:727]: Custom Action Manager thread ending.
MSI (c) (FC:9C) [13:34:37:728]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (c) (FC:9C) [13:34:37:728]: MainEngineThread is returning 1603
=== Verbose logging stopped: 8/31/2021 13:34:37 ===
pped: 8/31/2021 13:34:37 ===

MPSetup.log

<08/31/21 13:26:13> ======== Completed Installation of Pre Reqs for Role SMSMP ========
<08/31/21 13:26:13> Installing the SMSMP
<08/31/21 13:26:13> Passed OS version check.
<08/31/21 13:26:13> IIS Service is installed.
<08/31/21 13:26:13> No versions of SMSMP are installed. Installing new SMSMP.
<08/31/21 13:26:13> Enabling MSI logging. mp.msi will log to D:\Microsoft Configuration Manager\logs\mpMSI.log
<08/31/21 13:26:13> Installing D:\Microsoft Configuration Manager\bin\x64\mp.msi CCMINSTALLDIR="D:\SMS_CCM" CCMSERVERDATAROOT="D:\Microsoft Configuration Manager" USESMSPORTS=TRUE SMSPORTS=80 USESMSSSLPORTS=TRUE SMSSSLPORTS=443 USESMSSSL=TRUE SMSSSLSTATE=0 CCMENABLELOGGING=TRUE CCMLOGLEVEL=1 CCMLOGMAXSIZE=1000000 CCMLOGMAXHISTORY=1
<08/31/21 13:26:27> mp.msi exited with return code: 1603
<08/31/21 13:26:27> Backing up D:\Microsoft Configuration Manager\logs\mpMSI.log to D:\Microsoft Configuration Manager\logs\mpMSI.log.LastError
<08/31/21 13:26:27> Fatal MSI Error - mp.msi could not be installed.
<08/31/21 13:26:27> ~RoleSetup().
<08/31/21 13:34:23> ====================================================================
<08/31/21 13:34:23> SMSMP Setup Started....
<08/31/21 13:34:23> Parameters: D:\Microsoft Configuration Manager\bin\x64\rolesetup.exe /install /siteserver:OMSVR-SCM SMSMP 0
<08/31/21 13:34:23> Installing Pre Reqs for SMSMP
<08/31/21 13:34:23> ======== Installing Pre Reqs for Role SMSMP ========
<08/31/21 13:34:23> Found 1 Pre Reqs for Role SMSMP
<08/31/21 13:34:23> Pre Req SqlNativeClient found.
<08/31/21 13:34:23> SqlNativeClient is already installed (Product Code: {9D93D367-A2CC-4378-BD63-79EF3FE76C78}). But to support TLS1.2, a new version with Product Code: {B9274744-8BAE-4874-8E59-2610919CD419} needs to be manually installed
<08/31/21 13:34:23> Pre Req SqlNativeClient is already installed. Skipping it.
<08/31/21 13:34:23> ======== Completed Installation of Pre Reqs for Role SMSMP ========
<08/31/21 13:34:23> Installing the SMSMP
<08/31/21 13:34:23> Passed OS version check.
<08/31/21 13:34:23> IIS Service is installed.
<08/31/21 13:34:23> No versions of SMSMP are installed. Installing new SMSMP.
<08/31/21 13:34:23> Enabling MSI logging. mp.msi will log to D:\Microsoft Configuration Manager\logs\mpMSI.log
<08/31/21 13:34:23> Installing D:\Microsoft Configuration Manager\bin\x64\mp.msi CCMINSTALLDIR="D:\SMS_CCM" CCMSERVERDATAROOT="D:\Microsoft Configuration Manager" USESMSPORTS=TRUE SMSPORTS=80 USESMSSSLPORTS=TRUE SMSSSLPORTS=443 USESMSSSL=TRUE SMSSSLSTATE=0 CCMENABLELOGGING=TRUE CCMLOGLEVEL=1 CCMLOGMAXSIZE=1000000 CCMLOGMAXHISTORY=1
<08/31/21 13:34:37> mp.msi exited with return code: 1603
<08/31/21 13:34:37> Backing up D:\Microsoft Configuration Manager\logs\mpMSI.log to D:\Microsoft Configuration Manager\logs\mpMSI.log.LastError
<08/31/21 13:34:37> Fatal MSI Error - mp.msi could not be installed.
<08/31/21 13:34:37> ~RoleSetup().

Microsoft Configuration Manager
{count} votes

Accepted answer
  1. Pavel yannara Mirochnitchenko 12,371 Reputation points MVP
    2021-08-31T13:34:23.32+00:00

    I am just thinking, is there any chance your msi installer is broken? Could you try to install any small msi on that server, 7zip for example. This way we will ensure that the server OS msi installer is not corrupted. Anyway, also at meanwhile you should consider to check and fully patch your server OS.

    1 person found this answer helpful.

3 additional answers

Sort by: Most helpful
  1. Jason Sandys 31,181 Reputation points Microsoft Employee
    2021-08-31T14:29:38.877+00:00

    To troubleshoot 1603 errors in Windows Installer, you need to search the verbose MSI log file for the phrase "return value 3" and read up from there. This error is indicative of a custom action failing which is why Windows Installer has no detailed info on what actually failed.

    Have you tried simply rebooting the system the MP role is hosted on though? MP installation failures are often related to other components, like the client agent, requiring a reboot to finish successful installation.

    1 person found this answer helpful.
    0 comments No comments

  2. Amandayou-MSFT 11,051 Reputation points
    2021-09-03T08:27:37.543+00:00

    Hi @Kudzanayi Sabeta ,

    Haven't heard from you for some time, could we know if yannara and jason's recommendations are tried? Are their answers helpful to you when troubleshoot the issue? If they are helpful, please accept answer.

    If you have any other issues, please don't hesitate to let us know.

    Thanks and have a nice day.

    Best regards,
    Amanda

    0 comments No comments

  3. Pavel yannara Mirochnitchenko 12,371 Reputation points MVP
    2021-10-28T16:51:03.53+00:00

    This is actually very interesting to know, because I am about to patch few years old CM to 2701 build and want to make sure I will not have the same problems.