Network Card (WoL) Randomly Waking PC During Sleep

Monica 1 Reputation point

Hello, I was wondering if someone here could help me out with a network-related problem, please? I am trying to use Wake on LAN (WoL) to access my computer when I am away from my desktop, but my desktop cannot stay asleep because it keeps randomly being woken up by my network card. I have “Wake on Magic Packet” disabled and “Only allow a magic packet to wake the computer” checked, yet my desktop will randomly wake from Sleep Mode shortly after being put to sleep. It only stays asleep for less than thirty minutes. Is there a way to keep my desktop from randomly being woken up without me sending a magic packet to wake it up? Any help would be greatly appreciated!

Here is a list of some of my specs:

OS: Windows 10 Education

Motherboard: ASUS PRIME X470-PRO

Network Card: Intel Dual Band Wireless-AC 8265, PCI-E

Router: ASUS RT-AC1750 B1

Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,192 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 38,871 Reputation points

    Hello @Monica

    First of all you need to check what unexpectedly awakened windows

    Windows knows what activated your computer most recently, so the next time it wakes up unexpectedly, open the Start menu and search for “cmd”, right-click on Command Prompt and choose Run as Administrator . Type the following command and press Enter:

    powercfg -lastwake

    If you're lucky, you'll have a pretty clear answer.

    If this command didn't provide useful information, try this one:

    powercfg -waketimers

    I was also lucky when searching for information in Windows Event Viewer. Click on the Start menu, search for "Event Viewer" and launch the tool. In the sidebar, go to Windows Logs > System and click the Filter Current Log button on the right side of the window.

    Choose Power-Troubleshooter from the Event Sources drop-down menu and click OK to see all the times your computer was recently turned on and what caused them. Filtering by Kernel-Power can also help, but in my experience it is less likely to include useful data.

    Using this information, you can try some of the solutions below to prevent your computer from randomly waking up next time.

    1) Windows Update adjustment, scheduled maintenance

    With the correct version of Windows 10, open the Start menu, search for "Group Policy" and go to Computer Configuration > Administrative Templates > Windows Components > Windows Update , double click on Enabling Windows Update Power Management and set -o as Disabled .

    2) Find a misbehaving USB device

    If Windows reports that a USB device is activating your computer, you will have to find the problematic device, usually with the keyboard or mouse.

    If you have trouble figuring out which device is the problem, remove all your USB devices the next time you put your computer to sleep and see if it wakes up on its own. Otherwise, you can leave a device connected the next time you put it to sleep. Keep doing this until you find the offending device.

    Once you find the problematic hardware, open the Start menu and look for “Device Manager”. Find the device in the resulting list - say your keyboard - and right-click on it. Select Properties and the Power Management tab, uncheck Allow this device to wake up the computer, and click OK.

    3) Limit your network adapter

    One of my sleepless computers told me it was waking up thanks to an Intel(R) I211 Gigabit network connection. This is the Ethernet port that connects my computer to the Internet and it means that some kind of network activity is regularly waking up the computer. You can fix this in Device Manager.

    Open the Start menu, search for "Device Manager" and find the Ethernet or Wi-Fi adapter in question under Network Adapters. Right click on it, choose Properties and open the Power Management tab. Uncheck Allow this device to wake up the computer and you are ready to go.

    Alternatively, you can keep this box checked and check Only Allow a Magic Package to Wake Your Computer . This is useful if you use Wake-On-LAN to remotely access sleeping computers. This will ensure that Wake-On-LAN is still working, without allowing any network traffic to bring your computer out of sleep. This box is not checked by default, for some godless reason, and checking it solved my problem beautifully.

    4) Disable Other Wake Timers

    If none of the above solves your problem, you may have to research the wake-up timers configured on your computer - that is, scheduled events that are allowed to wake up your machine. Open the Start menu, search for "Edit Power Plan" and click Change Advanced Settings in the Edit Plan Settings window.

    Go to Sleep > Allow Wake Timers and change Battery and Connected to Disabled . You will want to repeat this process for all of your energy plans in the dropdown at the top, not just the one you are currently using.

    With that in mind, I also recommend opening PowerShell and running the following command:

    Get-ScheduledTask | where {$_.settings.waketorun}

    This can help you find scheduled tasks designed to wake up your PC. If you want to disable any, open the Start menu and search for "Task Scheduler", navigate to the task in question using the sidebar and double click to edit it. Select the Conditions tab and uncheck the Activate computer to perform this task box.

    If the answer was helpful, please don't forget to vote up or accept as an answer, thank you.