Windows defender MsMpEng.exe and mssense.exe were high memory consumption on the server

kumar kaushal 176 Reputation points
2021-09-02T14:11:35+00:00

The machine is a 2019 DC server .

 We do see that MsMpEng.exe and mssense.exe were high memory consumption on the server .
 Currently MsMpEng.exe and mssense.exe has been added to the exclusion list and also been said ScanAvgCPULoadFactor to 30 .

The question that i have :
I have made the process name listed in Exclusion list . How is process name then path exclusion list ? Is that i have to make the path for MsMpEng as the exclusion list ?

How can we troubleshoot as to why MsMpEng and Mssense is consuming high memory and CPU ?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,410 questions
0 comments No comments
{count} vote

4 answers

Sort by: Most helpful
  1. Limitless Technology 39,461 Reputation points
    2021-09-03T09:29:26.66+00:00

    Hello, @kumar kaushal ,

    It is quite normal for the Antimalware Service Executable to utilize high CPU usage. But as a background task, the Service is not supposed to utilize fore than 50% of the CPU resources. Since msmpeng.exe is the default program in Windows Defender or MSE, you cannot remove it. What you can do to resolve msmpeng high disk usage or high memory is to make adjustments to Windows defender or MSE.

    Not quite sure of how you managed the Windows Defender exclusion from Scanning MsMpEng Files, but this is one of the occasions when Windows Defender process MsMpEng.exe will not eat up 100% CPU on Windows 10 anymore.

    Other solution would be to reschedule Windows Defender Scan by changing the settings in the New Trigger window,for example the start time for scanning. Try to open the task manager and then check whether or not Windows Defender process msmpeng.exe still occupies much CPU

    Disable Windows Defender in Group Policy:

    Local Group Policy > Computer Configuration > Administrative Templates > Windows Components > Windows Defender Antivirus.
    Under Windows Defender Antivirus locate and double click Turn off Windows Defender Antivirus to configure it. Then In Turn off Windows Defender Antivirus, set it as Enabled and then hit Apply and OK to disable Windows Defender

    Of course you can always go for disabling the Microsoft Security Essentials

    I hope this opinion will help you further,
    Regards

    1 person found this answer helpful.
    0 comments No comments

  2. Bingo 6 Reputation points
    2022-08-24T11:54:11.22+00:00

    I had the same issue and found a way to do exclusion to MsMpEng.exe
    These problems cause Antimalware Service Executable on Windows Defender's exclusion list is the best and easiest solution to fix the problem.
    Press the Windows key plus I to open the Windows Security Settings. Select Update & Security after that.
    Following that, select Windows Security and then Virus & Threat Protection Settings.
    Under Exclusions, click Add or Remove.
    Choosing Process > Add an Exclusion.
    Click Add once you've typed MsMpEng.exe.

    1 person found this answer helpful.
    0 comments No comments

  3. Copolot 0 Reputation points
    2023-03-18T11:37:41.4666667+00:00

    I had the same problem before with Windows Defender and Microsoft Edge they both act like a malware cannot stop using windows task manager, they slow down processes and the worst is when you are playing game like valorant, Windows update runs in the background it is so irritating. So I remove them and disable windows updates.

    0 comments No comments

  4. Waqar Aslam 0 Reputation points
    2023-08-08T06:33:31.4866667+00:00

    just delete that virus file after opening task manager > click to details > click MsMpEng.exe > click to open file location > scan the destination & then delete the file. the problem will fixed!

    0 comments No comments