Exchange 2013 DAG All Active and Passive databases content index "Unknown"

Marcus Wong Theen Nam 1,111 Reputation points
2021-09-03T04:22:34.68+00:00

I have 2 nodes Exchange 2013 Cu 17 in DAG. When getting mailbox database copy status it shows that both active and passive copy is having "Unknown" in content index status. I was unable to update the database catalog since none of them has healthy copy.

I searched around few article and saw the following options that I could try:

  1. Check if ContentSubmitters group exist in AD, if not then create it and assign Full control to administrators and network services accordingly. Restart Exchange search host services
  2. Rebuild the database content indexes

As for option no.2, since my environment is a 2 node DAG, can I still rebuild the content index on Active node, and then update the database catalog on passive copy? Because what I can see people mostly saying that this solution is for standalone Exchange server which is not a member of DAG.

Thank you.

Exchange Server Development
Exchange Server Development
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Development: The process of researching, productizing, and refining new or existing technologies.
522 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,440 questions
0 comments No comments
{count} votes

Accepted answer
  1. Joyce Shen - MSFT 16,646 Reputation points
    2021-09-06T02:26:53.763+00:00

    Hi @Marcus Wong Theen Nam

    Yes, like you said above, if content index of all database including active database and passive database copy is unhealthy. Rebuild content index doesn't resolve this problem. Please check if there is any error log recorded in the application log through event viewer as well.

    Below is the solution provided in a thread which discussed about the similar issue as yours: Exchange 2013 Content Index status "unknown",

    Recreate the Search Foundation from scratch

    • Stop and disable the search services and rename the Data Folder "C:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\HostController\Data"
    • Open power shell and navigate to C:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\Installer
    • Run the command : .\installconfig.ps1 -action I -dataFolder "c:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\HostController\Data"
    • Output should be like

    [PS] C:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\Installer>.\installconfig.ps1 -action I -dataFolder "C:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\HostController\Data"
    Configuring Search Foundation for Exchange....
    Successfully configured Search Foundation for Exchange

    • Rename the Index files for the database that are active on the node .
    • Start the Search Services

    Removed a configuration entry that refers to the ContentSubmitters group. This entry is present in four XML files. Each file is called WcfConfigurator.

    • you can find each file in the following folder: %ExchangeInstallPath%\Bin\Search\Ceres\HostController\Data\Nodes\Fsis\NODENAME\Configuration\Local
    • Here, “%ExchangeInstallPath%” is the Exchange installation root path, and the placeholder NODENAME represents one of the following names. (There is one name for each of the four files that are to be edited.)

    AdminNode1
    ContentEngineNode1
    IndexNode1
    InteractionEngineNode1

    • These are text files. You can use Notepad or any other convenient plain text editor to change them. Make sure that you make only the change that is described here.
    • Each file contains at most one line that contains the following: <AuthorizedRole>ContentSubmitters</AuthorizedRole>
    • Remove this line, and then save the file. Repeat this operation for each of the four files, and then restart the Microsoft Exchange Search Host Controller service.
    • Found the Index files in Crawling state as expected instead of Unknown.

    Once all the Active copies are healthy and still the copies in failed and suspended state, then you can reseed the catalog files only using the below command
    Update-MailboxDatabaseCopy -Identity BD\MBserver –CatalogOnly

    In addtion, I mentioned that you Exchange server version in old now, it's better to upgrade your Exchange server to a newer version to get better support. Exchange Server 2013, and some tips for your upgrade

    The general process for applying upgrades to a DAG member is as follows:

    1. Put the DAG member in maintenance mode.
    2. Install the update.
    3. Take the DAG member out of maintenance mode and put it back into production.

    If an Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


0 additional answers

Sort by: Most helpful