Microsoft Edge version 93 .0.961.38 cannot login to Apple Support Community Forum and Apple Developer Forum

M Rusli 176 Reputation points
2021-09-03T08:54:40.8+00:00

After updating to the latest version of Microsoft Edge (version 93.0.961.38) today. I noticed that I unable to login to Apple Support Community Forum and Apple Developer Forum. The only way which I can do is to downgrade to the previous version of Microsoft Edge (92.0.902.84). That some how solve the problem.

These problems also have an issues with Google Chrome version 93. And that is confirmed.

Here is the methods to downgrade to old version from this website. https://www.microsoft.com/en-us/edge/business/download or https://www.microsoft.com/en-us/edge

Download the Stable 92 version which is 92.0.902.84.

Open the CMD as Administrator.

Go to the download file for example : C\users\yourusename\Downloads

and from the command prompt C;\Users\yourusername\Downloads> msiexec /i MicrosoftEdgeEnterpriseX64.msi ALLOWDOWNGRADE=1

Then go to Settings-> Apps -> Microsoft Edge, sellect Uninstall.

Reboot Windows 10 or Windows 11.

And go to the download folder again and double click on MicrosoftEdgeEnterpriseX64.msi which you have download earlier.

And try out to login to Apple Support Community Forum or Apple Developer Forum. Please take note that these are the work arounds at the moment until they fix the software bugs.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
11,164 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,501 Reputation points
    2021-09-03T12:53:49.987+00:00

    Hello,

    Thank you for your question and reaching out.

    Thanks for letting us know the workaround also you can try to clear cache and login using private mode to apple website to check if you able to login.

    If the reply was helpful, please don’t forget to upvote or accept as answer.

    0 comments No comments