RDP stopped working after installing Windows 10 21H1

Fu Wong 1 Reputation point
2021-09-07T08:26:00.62+00:00

HI,

I have been using RDP on my Windows 10 Pro for workstations Pc for the last year.
Suddenly after installing the update 21H1, RDP stopped working.

After checking many forums, I have checked/tried below:

  • Firewall is turned off
  • Antivirus is turned off
  • Both server and client on the same LAN segment
  • both running Windows 10 21H1
  • Registry setting configured to listen on port 3389
  • Exported registry setting from working PC to non working PC
  • used administrator accounts
  • disabled "allow RDP to this PC" rebooted, enabled "allow RDP to this PC"
  • I checked the services are running, but I am unable to run (not disabled. I tried manual and automatic):
    • Remote Access Auto Connection Manager
    • Remote Desktop Services UserMode Port Redirector
    • Secure Socket Tunnelling Protocol Service

When I run netstat -a -n -o, I find that the PC is not listening on port 3389.

How can I get those services running and the PC listening for RDP connections?

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,386 questions
Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,311 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. kym bob 6 Reputation points
    2022-09-28T04:11:42.123+00:00

    Why would the port end up being different from the default all of a sudden?

    1 person found this answer helpful.
    0 comments No comments

  2. Limitless Technology 39,506 Reputation points
    2021-09-07T11:52:38.187+00:00

    Hello @Fu Wong ,

    To check or change the RDP port, use the Registry Editor:

    Go to the Start menu, select Run, then enter regedt32 and navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\<listener>.

    If PortNumber has a value other than 3389, change it to 3389

    After you change the port number, restart the Remote Desktop Services service.

    Also i recommend you to kindly go through the below link,

    https://learn.microsoft.com/en-us/windows-server/remote/remote-desktop-services/troubleshoot/rdp-error-general-troubleshooting#check-the-rdp-listener-port

    https://answers.microsoft.com/en-us/windows/forum/all/remote-desktop-connection-not-working-port-3389/0d96ef22-ef86-41e0-9513-40724832c7ad?auth=1

    https://answers.microsoft.com/en-us/windows/forum/all/remote-desktop-connection-not-working-port-3389/0d96ef22-ef86-41e0-9513-40724832c7ad?auth=1&page=1

    --please don't forget to upvote and Accept as answer if the reply is helpful--

    0 comments No comments

  3. Joshua Thompson 156 Reputation points
    2022-10-14T12:54:27.417+00:00

    Similar problem here. Windows 10 21H2. Started happening back in August. I believe this was after the August updates but I cannot confirm.
    Users are intermittently unable to remote to their workstation. Their workstation is pingable. I can logon locally to their workstation with no issue.

    running netstat -ano on the impacted workstation shows that RDP is not listening on port 3389.
    Services.msc shows that the 'Remote Desktop Service' service is running.
    Attempting to restart the Remote Desktop Service service produces an error about unable to stop service (or something along those lines).

    We typically kill TermService.exe via the following powershell. We found the below works best when not run from the impacted machine itself but some other workstation.

    enter-pssession (remote computer name)
    Get-WmiObject -Query "select * from win32_service where name='TermService'"

    Stop-Process -ID (process ID from above)

    This stops TermService.exe (which appears to be the Remote Desktop Service service and then the service will start automatically back up on its own (due to the recovery options on the service)

    The 'Remote Desktop Service' service is now listening on port 3389 and users are able to remote to their computer.

    Our computers restart nightly. So sometimes after restart this is happening. I have not been able to figure this out yet.
    Nothing stands out in the logs.

    This is only happening on a small number of workstations in my office.
    I have not been able to figure out why the Remote Desktop Service service just stops listening on port 3389. I see no indications that something else has started listening on that port.


  4. Johnson, Jeffrey (BW-LYN) 1 Reputation point
    2022-10-21T12:36:19.92+00:00

    Stoopid update turned off RDP sessions.

    Start > Run > sysdm.cpl

    Click on Remote tab

    Select radio button to Allow Remote connections to computer

    That fixed it for me on my machines that had this same issue.

    0 comments No comments