virtual machine remote connection issue

Shuxin Yang (杨书新) 21 Reputation points
2021-09-07T10:47:55.357+00:00

Hi
I just created a virtual machine in azure, I followed the steps on MSDN to install a desktop env on VM, everything works perfectly before I try to connect the VM with windows "remote desktop connection" (Windows 10), I can get into the login interface, after I input my username and password, it flashes back to my desktop's "remote desktop connection".
I've tried to restart the vm but it did not work, I've also tried different sessions in the login form, every session shows a error form in the remote window
Is anything I've missed? any kind of advice would be great, thank you!

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,392 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,337 questions
{count} votes

Accepted answer
  1. KarishmaTiwari-MSFT 18,652 Reputation points Microsoft Employee
    2021-09-21T00:04:31.703+00:00

    Customer posted the answer in the private comment. Sharing here for others to refer.

    "The issue is regarding this link : https://learn.microsoft.com/en-us/azure/virtual-machines/linux/use-remote-desktop
    The problem I got is every time I type in the username and password in the xrdp interface, the remote window closes.
    I searched a lot and tried to repeat the steps, it turned out to be this command below probably got skipped.
    echo xfce4-session >~/.xsession
    Everything works perfectly after I run this command on my computer with powershell."

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Devaraj G 2,091 Reputation points
    2021-09-13T03:31:42.477+00:00

    I would recommend to enable boot diagnostics and check the screenshot of the VM for further troubleshooting.

    https://learn.microsoft.com/en-us/troubleshoot/azure/virtual-machines/boot-diagnostics

    0 comments No comments