How to perminantely disable windows 10 updates

Gillespie, Jess 26 Reputation points
2021-09-07T16:17:41.45+00:00

How can we completely disable windows 10 pro 20H2 update. We stopped the service and set it to disable, but over time the service restarts and updates continue to happen. Our systems do not have internet access so this causes a problem and sometimes restarts the computer.

thanks.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
11,127 questions
{count} votes

8 answers

Sort by: Most helpful
  1. kashanrat 26 Reputation points
    2022-02-16T03:50:21.5+00:00

    Disclaimer

    Credit goes to original finder (not me). This workaround disables ALL windows updates permanently and works on all windows 10 versions.

    >>Caution! Modifying the registry can cause serious system problems, if you do not know what you are doing. Disabling updates also puts you at risk of existing vulnerabilities<<<

    Do not attempt this method if “Update and shutdown” or “Update and restart” options are shown in power. The workaround is completely reversible so if you decide you want to enable updates later, you can do so.

    FOREWARNING:

    Microsoft Store will no longer be able to connect to internet (already installed programs will not be affected) -will be normal again once the process is reversed

    Windows defender - I don’t use this garbage so I can’t attest to the affected function of this component -will also be normal again once the process is reversed if it was affected. To be fair, no one uses that garbage anyways....

    VIDEO TUTORIAL OF THE SAME https://www.youtube.com/watch?v=6atgKRQjsKA

    Solution - Cut off access to the 3 services, "Update Orchestrator Service", "Windows Update", "Windows Update Medic Service"

    Method:

    Go to registry editor, and go to HKLM\SYSTEM\CurrentControlSet\Services

    Scroll down to UsoSvc>Right Click>Permissions>Advanced>Change owner>Advanced>Find Now>Select Administrator>OK>OK>Disable inheritance>Remove all inherited permissions from this object>Tick "replace all child object permissions...">Apply>Yes>Yes>OK>OK>OK

    Do the same for "WaaSMedicSvc" and "wuauserv"

    >>After changing as shown in video, no one will be able to read or write from them (including system and yourself)<<<

    To confirm: Run>Services.msc>Action>Refresh

    "Update Orchestrator Service", "Windows Update", "Windows Update Medic Service" should be having an error message in description

    Restart PC

    To confirm: Run>Services.msc>Action>Refresh

    "Update Orchestrator Service", "Windows Update", "Windows Update Medic Service" should have disappeared from the list.

    Open Windows Update window and it will display "Something went wrong. Try to reopen Settings later"

    If you decide you want updates later in life, you can just use the reversal method mentioned below and everything will be as it was.

    Reversing disabling updates

    Go to registry editor, and go to HKLM\SYSTEM\CurrentControlSet\Services

    Scroll down to UsoSvc and select it. Will give you an error. Press OK and close error window.

    Now UsoSvc is already selected>Right Click>Permissions>Press OK on warning window>Advanced>Press OK on warning window>Change owner>Advanced>Find Now>Select Everyone>OK>OK>Apply>Enable inheritance>Apply>Tick "replace all child object permissions...">Apply>Yes>>OK>OK>

    Do the same for "WaaSMedicSvc" and "wuauserv"

    Restart PC

    Enable and start the following services if not already running in services (Run>services.msc):

    -Update Orchestrator Service

    -Windows Update

    -Windows Update Medic Service

    3 people found this answer helpful.

  2. Kenneth Mason 6 Reputation points
    2022-03-11T03:53:16.817+00:00

    I have been recovering a customer's data with EaseUS data recovery wizard for five days now, lots of bad sectors, recovery was very intensive and slow. Drive getting hot in my external drive caddy. I put a fan on it and hoped for the best. This was probably my only chance, as the drive even started to fail. I was passing another customer's data for five website database cluster members from my workstation copy back onto the nodes in the datacenter. On my windows 10 home workstation I set my hours of activity for Windows update to 6am > 11pm. I had seen and closed the update pop-up a few times over the past two days or so.Today at 10:37 am WHILE typing - it rebooted. LOST all those days of extremely valuable precious life on the bad sectors data recovery hdd. Wasted all that time. Made that customer doubt my professionalism. RUINED a scheduled relocation of another customer's servers and databases, upsetting five Unix Sysadmins and a testy coder and probably causing our loss of this contract. JUST WHO DO MICROSOFT THINK THEY ARE? I don't need to pay more for any "Professional" windows version - all I need is Windows HOME and putty. And I need it to not think more highly of itself than this nation's commerce or the photos of a family's children's entire lives. This goes way beyond unforgivable. All of my customers will know about the depths microsoft will stoop to in the name of version up-sell. This is petty, greedy vandalism and theft of services and destruction of data. VILE, microsoft. YOU ARE BANNED.

    1 person found this answer helpful.

  3. S.Sengupta 17,121 Reputation points MVP
    2021-09-08T01:20:50.56+00:00

    You can pause the update as suggested here:

    Manage updates in Windows 10

    Here are tips on how to permanently turn off Windows Update....

    0 comments No comments

  4. Limitless Technology 39,506 Reputation points
    2021-09-08T07:59:15.83+00:00

    Hello,

    Thanks for reaching out.
    You may check below GPO settings to prevent updates being installed.

    If the device is running Windows 10 Pro or Enterprise, you can use the Group Policy Editor to set target feature update version.
    To configure a target feature update version with Group Policy, use these steps:
    Search for gpedit and click the top result to open the Group Policy Editor.
    Browse the following path:
    Computer Configuration > Administrative Templates > Windows Components > Windows Update > Windows Update for Business
    Double-click the Select target Feature Update version policy.
    Check the Enabled option.
    Under the “Options” section, confirm the target version of the feature update you want to set the device.

    Thanks,

    0 comments No comments

  5. Kapil Arya 7,856 Reputation points MVP
    2021-09-08T11:50:39.833+00:00

    Hello,

    You can use Group Policy to block automatic updates. This ensures updates are downloaded/installed only when you want them:

    1. Open GPO snap-in by running gpedit.msc command.
    2. Go to Computer Configuration -> Administrative Templates -> Windows Components -> Windows Update.
    3. Double click Configure Automatic Updates policy setting, select Enabled. Then under 'Configure automatic updating' section, choose 2 - Notify for download and notify for install.
    4. Click Apply, followed by OK.

    Multiple reboots will finally disable auto updates.

    Reference: https://www.kapilarya.com/avoid-windows-updates-automatic-download-windows-10

    Let us know if this helps!

    Note: Included link in this reply refers to blog post by a trusted Microsoft MVP.