RDP replacement for Win10?

JDMils 51 Reputation points
2021-09-08T03:36:27.657+00:00

My home desktop computer has 2x 27" monitors and I use it to RDP to my single-screen older work HP notebook- the result is my notebook is shown as 2 extended screens on my home computer.

Work sent me a new IBM single-screen notebook, and I can RDP to it and see the notebook on my home desktop on both monitors, however the RDP session slows right down to the point where it takes about 2 seconds for each character to type on the screen. I've tried to fault the issue and cannot find a solution.

I thus am looking for another remote-control solution which can do the following:
* Show the notebook as 2 extended screens on my home desktop.
* Does not require authentication such as TeamViewer. It's a pain when the 2 computers are in the same room and I have to take the password from one and enter it onto the other just to connect.
* Preferably free but would consider paying a small amount if it works.

So I really want all the features of RDP without using RDP.

IBM notebook details:
Thinpad X1 Carbon Gen8
Type 20u9-S04L00
OS Name: Microsoft Windows 10 Enterprise
OS Version: 10.0.19042 N/A Build 19042
OS Manufacturer: Microsoft Corporation

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,341 questions
Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,293 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,476 Reputation points
    2021-09-08T09:12:53.94+00:00

    Hello JDMils,

    As far as I am aware all current mainstream (and trusted) remote access tools will require a 2 way confirmation (either with pin, password, or just clicking on accept). This is logically because of security.

    However you can check in their settings to change the behavior, for example in teamviewer the option in: Extras -> Options -> Advanced -> click Show Advanced options -> and scroll down to "Advanced settings for connections to other computers" and check if you have under Access Control set to: Confirm all, if you have so change it to Full Access and save the settings by clicking OK.

    This should help you,
    Best regards!

    0 comments No comments