Microsoft Endpoint Manager app deployment

Matt Standing 1 Reputation point
2021-09-08T15:56:39.213+00:00

Hi,

I am trying to deploy an app using Endpoint manager and I'm running into the same issue - "file not found"

The application consists of multiple subfolders, with the setup program buried deep in the structure.
The application has been packaged using the intune packager and uploaded.

When I specify the executable path I have tried:

.\folder1\folder2\folder3\setup.exe -switch1 -switch2 -switch3
\folder1\folder2\folder3\setup.exe -switch1 -switch2 -switch3
".\folder1\folder2\folder3\setup.exe -switch1 -switch2 -switch3"
"\folder1\folder2\folder3\setup.exe -switch1 -switch2 -switch3"

But nothing seems to work. Can anyone suggest anything?

Thanks in advance,
Matt

Microsoft Intune Application management
Microsoft Intune Application management
Microsoft Intune: A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.Application management: The process of creating, configuring, managing, and monitoring applications.
906 questions
0 comments No comments
{count} votes

12 answers

Sort by: Most helpful
  1. Domagoj Novak 586 Reputation points
    2021-09-08T21:17:17.473+00:00

    Hi,

    Try specifying file path with variable "%~dp0".

    Example:
    File that is executed is located in C:\Temp\test.cmd

    If you run the %~dp0 in the test.cmd it will return "C:\Temp\" - directory path where it is executed from.

    So, if you want to run another script/installation file from main installation file (in this case C:\Temp\test.cmd) that is located in C:\Temp\temp2 simply write:
    "%~dp0temp2\installationpart2.cmd"

    I use %~dp0 in my deployment scripts all the time.

    Hope it helps you!

    Kind regards,
    Domagoj Novak

    0 comments No comments

  2. Crystal-MSFT 45,011 Reputation points Microsoft Vendor
    2021-09-09T06:07:01.6+00:00

    @Matt Standing , Agree with Domagoj, We can consider to use a batch file to run the install command and use "%~dp0" as a relative path. Here are some examples for the reference:
    http://eddiejackson.net/wp/?p=29630
    https://www.petervanderwoude.nl/post/deploy-customized-win32-apps-via-microsoft-intune/
    Note: Non-Microsoft link, just for the reference.

    Hope it can help.


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  3. Matt Standing 1 Reputation point
    2021-09-09T06:42:56.643+00:00

    Thanks I'll give it a go. To confirm, my install command in the app deployment section will now look something like:

    %~dp0folder2\folder3\setup.exe -switch1 -switch2 -switch3


  4. Matt Standing 1 Reputation point
    2021-09-09T07:00:18.397+00:00

    Thank you. Not sure if I can use quotes as one of the switches already requires quotes:

    %~dp0CATIA_PLM_Express.win_b64\1\WIN64\startb.exe -ident R30 -newdir -orbixport 1570 -orbixbase 1590 -orbixrange 200 -noLang "fr ge it ru jp ch ko" -addUserPrivilegesForOrbix -all -noreboot


  5. Matt Standing 1 Reputation point
    2021-09-09T09:35:18.39+00:00

    The install starts, sits at "Pending" for about 30 mins and then fails with the same error.

    To confirm, the source files are located in c:\temp\CATIA_R30

    130751-intune-1.jpg

    The setup file is located in C:\temp\CATIA_R30\V5-6R2020.CATIA_PLM_Express.win_b64.1-2\1.CATIA_PLM_Express.win_b64\1\WIN64:

    130761-intune-2.png

    I use the following values for the Intune packager:

    130696-intune-3.png

    And the following app deployment paths:

    130688-intune-4.png

    0 comments No comments