Mic get muted when i disconnected from RDP

Akila Indusara 1 Reputation point
2021-09-08T22:07:42.547+00:00

I'm trying to see if I can use my music bots in an azure VM. when I connected to the VM using RDP and connect bots to the TeamSpeak server I want and play the music (using sinusbot) it works fine. but when I get disconnected from the VM, the bots get muted automatically. is there any reason for that?

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,416 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,346 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Devaraj G 2,091 Reputation points
    2021-09-13T10:42:25.903+00:00

    its by behavior. there is no native way to suppress the auto mute.

    However there are work around listed here. see if this helps for you.

    https://forum.sinusbot.com/threads/disconnecting-rdp-bot-mutes-it-self.5521/

    2 people found this answer helpful.
    0 comments No comments

  2. ChristopherW-MSFT 1,681 Reputation points
    2021-09-08T22:48:05.13+00:00

    Hi @Akila Indusara ,

    It sounds like closing the RDP session is stopping the user session and it's pausing or ending the bot. You'll probably need to keep the session running after RDP disconnection for the bot to continue. You can keep a Remote Desktop Session open by enabling 'Configure keep-alive connection interval' in Remote Desktop Services.

    This setting can be enabled under Windows Group Policy Editor.

    Start > Administrative Tools > Group Policy Management  
    Local Computer Policy/Computer Configuration/Administrative Templates/Windows Components/Remote Desktop Services/Remote Desktop Session Host/Connections  
    In Connections set 'Configure keep-alive connection interval' to Enabled > Set Keep Alive Interval (Minutes) > OK  
    

    If you login to a different Session/User, you should see that the first session is still active. You can change between these Sessions by closing Bastion and starting a new session, or by going to Task Manager > Users > Right Click User > 'Connect'

    130319-image.png