SCCM CB 2107 client Issue

karthik palani 1,016 Reputation points
2021-09-09T13:14:32.08+00:00

Hi All,

I have upgraded SCCM Server to CB 2107, all clients and site components are recovered.

  • But i am facing an issue on one client machine which has DNS/DC running on it. I get the below error stating "Unknown namespace". Tried WBEMTEST and connected to services as well which i presume its not WMI connectivity issue. I tried multiple restart/reinstallation of client but still i get the below error. Please advice

130708-client-issue1.jpg

  • Also for new installed clients, i need to choose approved after right clicking on the machine. These machines are within the trusted domain. Is there any specific reason why it is asking for any approval instead automatic for trusted domain (I set the same in hierarchy settings)
Microsoft Configuration Manager
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Rahul Jindal [MVP] 9,391 Reputation points MVP
    2021-09-09T21:16:59.543+00:00

    How are you installing the client? Logon session would indicate use of /logon switch in the command line parameters which skips the installation if an existing agent is found.

    0 comments No comments

  2. AllenLiu-MSFT 41,691 Reputation points Microsoft Vendor
    2021-09-10T06:28:44.303+00:00

    Hi, @karthik palani
    Thank you for posting in Microsoft Q&A forum.

    isWindows10Orabove:Failed to get OS version with error 0x80004005
    What is the OS version of this client?

    Try to make below script a BAT and run on the client to see if it helps:

    Net Stop winmgmt  
    C:   
    CD%SystemRoot%\System32\wbem   
    RD /S /Q repository   
    regsvr32 /s %SystemRoot%\system32\scecli.dll   
    regsvr32 /s %SystemRoot%\system32\userenv.dll   
    for /f %%s in ('dir /b /s *.dll') do regsvr32 /s %%s  
    scrcons.exe /regserver  
    unsecapp.exe /regserver  
    winmgmt.exe /regserver  
    wmiadap.exe /regserver  
    wmiapsrv.exe /regserver  
    wmiprvse.exe /regserver  
    mofcomp cimwin32.mof   
    mofcomp cimwin32.mfl   
    mofcomp rsop.mof   
    mofcomp rsop.mfl   
    for /f %%s in ('dir /b *.mof') do mofcomp %%s   
    for /f %%s in ('dir /b *.mfl') do mofcomp %%s   
    ECHO.  
    ECHO DONE, please reboot...  
    ECHO.  
    Pause  
    

    For your reference:
    https://social.technet.microsoft.com/Forums/en-US/61a9a235-7f07-4ce6-9dff-6ff146f484cb/ccm-client-installation?forum=configmanagergeneral

    These machines are within the trusted domain still ask for approval even you have set "Automatically approve computers in trusted domains", does this also happened after upgrade to 2107?


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  3. IT 1 Reputation point
    2021-11-09T13:56:59.13+00:00

    Did you ever solve this? This is happening to us on some clients during OSD since we promoted the 2107 client.

    It seems it's only laptops but this is a big problem for us.

    0 comments No comments