How to fix WslRegisterDistribution failed with error: 0x800106d9 ?

Md Hammaduddin 6 Reputation points


How to fix WslRegisterDistribution failed with error: 0x800106d9 ?


**My Windows Specifications :

Edition Windows 10 Pro
Version 20H2
Installed on ‎12/‎22/‎2020
OS build 19042.867
Experience Windows Feature Experience Pack 120.2212.551.0

I have enabled the "Windows Subsystem for Linux" optional feature.
I hava enabled the 'Virtual Machine Platform' optional component
I have installed the wsl kernel
I have set WSL 2 as my default version
I tried Ubuntu20.04 , debain and kali, and then both encountered the same problem
I tried restarting and reinstalling, but the problem is still not solved
And when I press any key to continue, I see the terminal closes

How can I resolve this problem?**

Windows 10 Compatibility
Windows 10 Compatibility
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Compatibility: The extent to which hardware or software adheres to an accepted standard.
459 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,416 Reputation points


    for sure the easiest way to solve this issue is to reset from Kali App Settings or uninstall and reinstall the app.

    You can use wslconfig.exe and wsl.exe:

    C:\Users\username>wslconfig.exe /list
    Windows Subsystem for Linux Distributions:
    Ubuntu (Default)

    C:\Users\username>wslconfig.exe /setdefault kali-rolling

    username@user-name:/mnt/c/Users/username$ <back up files to somewhere in DrvFs>

    Or try running bash and update the subsystem - no reinstall would be required:

    open a commandline Shell

    C:\> bash
    $ sudo apt-get update
    $ sudo apt-get dist-upgrade
    $ <CTRL-D>
    C:\> exit

    You have to run Command Prompt as admin.

    Check also if the ICS(Internet Connection Sharing) service is started.


    2 people found this answer helpful.