DFExecutorUserError abfss://<data lake path>@<XXXXXX.dfs.core.windows.net>/ has invalid authority.

sachin gupta 376 Reputation points
2021-09-10T02:41:29.813+00:00

Hello,

I have created a data transformation which picks the 2 set of files from Azure Data Lake directory and then do the join and sink the resultant file in Azure Data Lake directory.
For the above scenario I created a Dataset which is pointing to the desired location where I have the 2 set of file which are .csv format. My dataset connection is failing and giving me below error

Error code: DFExecutorUserError
Details: abfss://<data lake path>@<XXXXXX.dfs.core.windows.net>/ has invalid authority.

When I change the directory location to something else, the dataset connection works fine. I did the research on this error, but not getting any guidance on this.

Would really appreciate if someone can help on this issue ASAP.

Thanks,
Sachin

Azure Data Lake Storage
Azure Data Lake Storage
An Azure service that provides an enterprise-wide hyper-scale repository for big data analytic workloads and is integrated with Azure Blob Storage.
1,398 questions
Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,927 questions
{count} vote

3 answers

Sort by: Most helpful
  1. sachin gupta 376 Reputation points
    2021-09-15T18:26:19.397+00:00

    @MartinJaffer-MSFT ...yes you got a right understanding. I spoke to the Admin of the Azure account who setup the blob storage and they mentioned that all the SAS account access is same for all directories in Storage container.

    a support ticket would be great, but the only problem is my work is on work machine and I won't be able to share the screen from there. Please let me know how we can proceed


  2. Nitika Rawat 1 Reputation point
    2022-08-02T11:26:05.583+00:00

    I have the same error is there any solution to that?

    0 comments No comments

  3. robin 0 Reputation points
    2023-03-29T18:57:37.0166667+00:00

    I got the same error with data flow. Any resolutions ?