How to prevent the update to windows11 in the future

heeha45 41 Reputation points
2021-09-10T05:56:53.77+00:00

Dear,
Currently we are using windows 10 Pro and windows 10 Entreprise. As we know that windows 11 is going to be released soon, we are not ready to update yet and may I know what is the setting to prevent the auto update?

Thankyou

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,943 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,612 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Kapil Arya 7,776 Reputation points MVP
    2021-09-10T06:05:15.487+00:00

    Hello,

    You can set a target Windows 10 version first:

    https://www.kapilarya.com/select-the-target-feature-update-version-in-windows-10

    Additionally, you can use Group Policy to block automatic updates. This ensures updates are downloaded/installed only when you want them:

    1. Open GPO snap-in by running gpedit.msc command.
    2. Go to Computer Configuration -> Administrative Templates -> Windows Components -> Windows Update.
    3. Double click Configure Automatic Updates policy setting, select Enabled. Then under 'Configure automatic updating' section, choose 2 - Notify for download and notify for install.
    4. Click Apply, followed by OK.

    Multiple reboots will finally disable auto updates.

    Reference: https://www.kapilarya.com/avoid-windows-updates-automatic-download-windows-10

    Let us know if this helps!

    Note: Included links in this reply refers to blog post by a trusted Microsoft MVP. 


  2. Reza-Ameri 16,846 Reputation points
    2021-09-10T14:34:48.977+00:00

    In case you manage Windows Update in your organization using WUfB or WSUS or other methods, you may manage and block Windows 10 Upgrade.
    Microsoft will share methods to block the upgrade.
    Normally, the free upgrade will be deployed to non-Manage devices (e.g. home devices) first.

    0 comments No comments