Removing hidden mapped drive properties

Marjan P 1 Reputation point
2021-09-10T21:26:05.123+00:00

Hi,
I want to make a hidden mapped drive ( For example F:) on OU1. I created it with GP in User Configuration -> Preferences -> Windows Setting - Drive Maps.
For users in OU2 mapped drive should not be hidden.
The problem is when I move a user from OU1 to OU2 , the original mapped drive is still hidden. Even if I mannualy delete this mapped drive ( or remove the mapped drive through another GP ), it removes mapped drive, but when I create mapped drive ( for F:) on OU2, it will be hidden.
How can hidden properties be removed from one drive letter after moving the user from OU1 to any other OU?
Somehow hidden Mapped Drive properties stick to the user!!!
Thanks,
Marjan P

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,927 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,461 Reputation points
    2021-09-13T12:53:55.697+00:00

    Hello MarjanP,

    I would recommend to check the registry of one of those users, as well the machine applicable policy.

    In the registry, you can check the next keys. Value should be "0" for none hidden drives (this might be a workaround for users in OU2, by modifiying the registry key by GPO on logon)

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

    Also, restore any Local policy if any using the next command from elevated command promtp:
    secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

    then reset downloaded policies
    RD /S /Q "%WinDir%\System32\GroupPolicyUsers"
    RD /S /Q "%WinDir%\System32\GroupPolicy"
    gpupdate /force

    Hope this helps with your issue,
    Best regards,

    0 comments No comments