Disable settings of redirected printers to be default on RDP

Azazel90 391 Reputation points
2021-09-13T12:39:24.97+00:00

We're setting up a RDS server and notice that redirected printers are set to be the default on RDP if they're set to be the default on the local machines. We cannot disable printer redirection so it's not a solution. Setting a default printer from GPO is also not a solution since almost everyone has a different default printer. Is there a way to allow users to take their local printers to the RDP session without messing up the previously set default printer on the RDS?

Example for the issue:

  1. On the user computer the local default printer is Printer_A
  2. RDS default printer has been set to Printer_B in the last connection of the user
  3. User connects to RDS now and the RDS default printer for their session changes to Printer_A

Is there a way to allow the redirection of Printer_A without changing the RDS default printer to Printer_A?

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management updated to data storage.
2,429 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,391 questions
Windows Server Printing
Windows Server Printing
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Printing: Printer centralized deployment and management, scan and fax resources management, and document services
655 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,496 Reputation points
    2021-09-14T13:35:48.013+00:00

    Hello,

    Thank you for your question.

    I would like to suggest you to check below Troubleshooting steps.

    1. In Windows 10 , Please make sure IIS is Uninstalled completely , you can verify from from Program and Features ->Turn on Windows features on or off
    2. In Windows Server , Open Server Manager - > Click on Manage -> Remove Roles and Features- > Features- > Untick IIS hostable core.
    3. Check where 443 port is being used on your server.

    3.a Type netstat -aon | findstr '[port_number]'. Replace the [port_number] with the actual port number that you want to check and hit enter.

    3.b If the port is being used by any application, then that application's detail will be shown. The number, which is shown at the last column of the list, is the PID (process ID) of that application. Make note of this.

    3.c Type tasklist | findstr '[PID]'. Replace the [PID] with the number from the above step and hit enter.

    3.d You'll be shown the application name that is using your port number.

    Hope this helps,