Excel can not open

HMP Harshana 1 Reputation point

My excel can not be open. I faced ms excel can't open or save any more documents because there is not enough available memory or disk space but my C drive has 100GB space. I deleted my temp file and reinstall office 365 but did not open excel. please help

Office Development
Office Development
Office: A suite of Microsoft productivity software that supports common business tasks, including word processing, email, presentations, and data management and analysis.Development: The process of researching, productizing, and refining new or existing technologies.
2,444 questions
Excel Management
Excel Management
Excel: A family of Microsoft spreadsheet software with tools for analyzing, charting, and communicating data.Management: The act or process of organizing, handling, directing or controlling something.
1,414 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Viki Ji_MSFT 4,301 Reputation points

    Hi @HMP Harshana ,
    Welcome to Q&A forum!

    Is the error message shown below? Please describe complete error messgae or share a screenshot with us.

    "Microsoft Excel cannot open or save any more documents because there is not enough available memory or disk space.
    To make more memory available, close workbooks or programs you no longer need.
    To free disk space, delete files you no longer need from the disk you are saving to.

    Since the issue occurr on the specific files, it may be the file-specific issue.
    Plase confirm the following information with us:

    • What the extension of the new file? Please change the file extension to check this issue.
    • How did you get the new file? Did you download it from Internet or create it yourself? Please create a new blank file to check this issue.
    • And where did you store the files? Please change the storage location for a check.

    I suggest you add the folder where these files are stored as a trusted location for Excel:
    In Excel, go to File>Options>Trust Center>Trust Center Settings>Trusted Locations. Click Add new location, and browse to the folder where you store your Excel files, select Subfolders of this location are also trusted, and click OK.

    Besides, please open the Excel app first, and go to File>Open to open the file to check if the issue exists.
    If conditions permit, I also suggest that you copy the error file to another PC to check if it could be opened normally.

    Any updates, pelase let me know.

    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.

  2. Vishal Jaiswal 1 Reputation point

    Try these steps:

    1. right click on the excel file
    2. go to the properties
    3. In general section, click on the unblock and apply

    Hope that would work.