testconnectivity.microsoft.com does not work anymore - SSL negotiation error

BK IT Staff 246 Reputation points
2021-09-14T15:24:49.847+00:00

We have been experiencing a problem with the tool for a few weeks now. We've been using it for years without any issues.

Basically, either that I use it for ActiveSync or Outlook Anywhere connectivity tests, I get the same error message:

131925-immagine.png

"The certificate couldn't be validated because SSL negotiation wasn't successful. This could have occurred as a result of a network error or because of a problem with the certificate installation."

My users seem to not have any problems when using Exchange services (OWA, ActiveSync, Outlook anywhere).

Since I've been struggling on this issue for a few days now, can you give me some advice on where to look to guess what the problem is? What I can tell is:

-Did not make any firewall/networking changes that I'm aware of.
-Did not install any updates on Exchange, nor I made any changes to the configuration.
-My cert is valid and current.

Perhaps, could it be due to some change to the tool itself (cipher suites, tls protocols etc)?

Thank you,
Francesco

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,440 questions
{count} votes

Accepted answer
  1. Xzsssss 8,861 Reputation points Microsoft Vendor
    2021-09-15T07:26:53.65+00:00

    Hi @BK IT Staff ,

    Please also check the Outlook Connectivity with Autodiscover.
    BTW, what's the version of your server?

    I could successfully test it with Autodiscover, but the ActiveSync failed with some SSL errors.
    I think some parts of the programming of EXRCA could be wrong, if your system is running correctly, just ignore the test result.

    Best regards,
    Lou


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.
    0 comments No comments

8 additional answers

Sort by: Most helpful
  1. Jonathan Holloway 11 Reputation points
    2021-09-15T07:14:21.717+00:00

    I am experiencing the same result, without changes. I too am suspecting SSL/TLS/Cipher changes are at play.

    2 people found this answer helpful.

  2. BK IT Staff 246 Reputation points
    2021-09-15T10:57:35.59+00:00

    Hi @Xzsssss , I ran the autodiscover test with Outlook 2016 (the test that you can run by doing ctrl+right click on outlook icon in the systray) from a laptop connected through my mobile hotspot to simulate an external connection request. No issues at all.

    My Exchange version is 2013 CU23.

    So, I will ignore the exRCA errors in the future, though I hope the exRCA developers will fix the issue asap, since that tool is really useful when you need somthing on the go for testing Exchange issues.

    Thank you.
    Francesco

    1 person found this answer helpful.
    0 comments No comments

  3. DION Jean-Michel 6 Reputation points
    2021-09-16T08:52:24.79+00:00

    Hi,

    The test failed only on EXRCA.
    Outlook test Email autoconfigurations work.

    I use EXRCA for testing an hybrid setup.

    I think too it's an issue with EXRCA.

    BR

    1 person found this answer helpful.
    0 comments No comments

  4. 2021-09-15T09:31:52.457+00:00

    Same problem here with Exchange 2013.

    I'm also experiences that setting up new Outlook profiles won't work outside the building. So I think there's definitely a problem with autodiscover. Couldn't found out what it is yet.