Certificates created by "Create App Service Managed Certificate" has invalid time value

Chris Yoon 21 Reputation points
2021-09-14T23:27:32.95+00:00

Hello,

  1. I've created a managed certificate on my app service using "Create App Service Managed Certificate" button below. 132047-image.png
  2. However, after the certificate is created, it is missing Expiration and Thumbprint as shown below. 132059-image.png
  3. Upon clicking on the certificate, I see an error saying "Invalid time value" 132132-image.png

Why would this happen?

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,135 questions
{count} votes

Accepted answer
  1. brtrach-MSFT 15,451 Reputation points Microsoft Employee
    2021-09-15T03:38:12.86+00:00

    @Chris Yoon Thank you for your patience on this matter. We located the latest update on the matter.

    The product group is aware of the issue and issued a hot fix to the canary portal. We suggest you use this portal until the full fix is released.

    Canary portal: https://aka.ms/canary

    There is no ETA to share right now as to when the fix will go into production. Please use the workaround for the meantime and we will update you with an ETA when hear something. We will reply to this answer via a comment with the ETA update.

    Let us know if there are any questions or concerns in the meantime.


2 additional answers

Sort by: Most helpful
  1. Jonas Aebersold 1 Reputation point
    2021-09-15T06:06:13.047+00:00

    We use azure automation and powershell and running in the same issue at the moment. We cannot use the portal, because the users don't have access to the portal.

    Our script use the command New-AzWebAppSSLBinding, which needs the thumbprint of the certificate. Do you have any workaround, how we can get the thumbprint?

    As a developer myself, I can understand that you cannot give an ETA. But I really hope that you are aware, that our hole workflow is broken and that we have customers asking us the same thing. This is a bad way to start a day.

    132226-image.png
    132227-image.png

    0 comments No comments

  2. Jonas Aebersold 1 Reputation point
    2021-09-15T06:52:03.383+00:00

    The day is getting better. I was in the "Help + support" section in the Azure Portal and a chat window opened up. It gave me the hint to this REST call:

    https://learn.microsoft.com/en-us/rest/api/appservice/web-apps/create-or-update-host-name-binding

    https://management.azure.com/subscriptions/{<!-- -->{sub}}/resourceGroups/{<!-- -->{rg}}/providers/Microsoft.Web/sites/{<!-- -->{appname}}/hostNameBindings/{<!-- -->{example.com}}?api-version=2019-08-01
    {
    "id": "/subscriptions/{<!-- -->{}}/resourceGroups/{<!-- -->{}}/providers/Microsoft.Web/sites/{<!-- -->{appname}}",
    "kind": "app",
    "location": "{<!-- -->{location}}",
    "name": "{<!-- -->{appname}}",
    "type": "Microsoft.Web/sites ",
    "properties": {
    "hostname": "{<!-- -->{example.com}}",
    "sslState": "SniEnabled",
    "ipBasedSslResult": null,
    "virtualIP": null,
    "thumbprint": "",
    "toUpdate": true,
    "toUpdateIpBasedSsl": null,
    "iPBasedSslState": "Configured",
    "hostType": "Standard"
    },
    "tags": null
    }

    I tried the call and it really worked.

    0 comments No comments