One of my harddrive volumes is write protected out of the blue and i am unable to copy files to it.

Mat 106 Reputation points
2021-09-15T06:03:54.073+00:00

I am running Windows 10 Pro (version 21H1) (OS Build 19043.1237)

I use Bitlocker on all my drives, volumes, partitions!!

One of my NTFS Volumes (Bitlocker protected) is out of the blue giving me the Disk is Write-protected Error when I try to copy files to it. After checking reg-edit (Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control) & Diskpart I found read-only is not set on the volume. Please see screen shot.

132264-screen-shot-copy.jpg

I do implement STIGS and have several Local Policies enabled after following the STIGs for windows 10. Could it be a Local Computer Policy? if so why would the policy affect one NTFS Volume and not the others.

Can anyone point me in the right direction to resolve this issue?

thanks

Mathew

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,974 questions
0 comments No comments
{count} votes

Accepted answer
  1. Mat 106 Reputation points
    2021-09-16T04:41:16.333+00:00

    Thanks,

    disk part would normally fix this, but in this case disk-part had no effect. I had a local policy in place that required bitlocker to use auto unlock or smart card login when unlocking the drive. using the password to unlock the drive made the disk read only. once I changed the bitlocker unlock method to Auto unlock the read-only issue was fixed.

    Solved It!!!!!!

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Limitless Technology 39,466 Reputation points
    2021-09-15T10:37:04.433+00:00

    Hello @Mat ,

    You should be able to remove the read-only with Diskpart:

    Run DISKPAR

    Type LIST DISK and press Enter

    Type the command SELECT DISK <number> and press Enter.

    Type ATTRIBUTES DISK CLEAR READONLY

    Regarding the local policies I would focus in the ones at: >Computer Configuration >Policy > Windows Setting > Security Setting > File System, maybe there is some lock there.

    Hope this helps,
    Best regards,

    1 person found this answer helpful.