A .Net Framework error occured during execution of user-defined or aggregate "deploy_project_internal":

isteyak ahmad 1 Reputation point

Hi Team,

I am using SQL server 2016 developer addition and Visual studio Community 2017 addition for SSIS package development and deployment.

When I am trying to deploy my package I am get132230-frameworkerror.pngting Attached error :
Kindly advise me how I can resolve this issue.

Isteyak Ahmad

SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
2,085 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. ZoeHui-MSFT 22,216 Reputation points

    Hi @isteyak ahmad ,

    Try with below methods to see if it is useful.

    Go to Windows Services, right click SQL Server (MSSQLSERVER) > properties > Log On > Tick the 'Local System account' radiobutton. Restart the service by right clicking SQL Server (MSSQLSERVER) again and clicking restart.


    If it doesn't work, change the locale of the Locale System account to en_US and the id to 00000409. Go to RegEdit -> HKEY_USERS -> [SID Local Admin] -> Control Panel -> International and change keys "Locale" and "LocaleName" for the desired region.

    Reference: https://stackoverflow.com/questions/21135511/ssis-error-while-deploying-package-the-locale-identifier-lcid-is-not-supported



    If the answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.
    Hot issues October

    0 comments No comments

  2. isteyak ahmad 1 Reputation point

    Hi Zoehui,

    I Tried both the option still getting the same error.

    Do I need to start any service after that.

    Isteyak Ahmad

  3. isteyak ahmad 1 Reputation point

    Hi @ZoeHui-MSFT

    Tried Installing on different machine and also restarted on my machine, however same error coming.
    Also i installed 2014,2016 and 2019 version of SQL all having the same issue.
    Seems some setting while installing SQL server is causing the error.

    Please advise if I need to try something else.

    Isteyak Ahmad