My server is not booting with 2 network card

Lavan.96 1 Reputation point
2021-09-15T11:04:29.487+00:00

Hi,
Some server exerts can you please help.
I have set up a standalone server with AD, DNS, DHCP and WDS.
I have 2 network cards on the server I set up.
I have all the time used local network without internet acess on the main card.
The other network card I connect the 4G router directly.
Once I have done this, I am unable to boot the PCs through WDS. It appears that the server does not assign any IP addresses to the clients. When I unplug the network cable I have, I have to boot it again.
I need our internet on the server to update it anytime.
Anyone know what the cause may be? possibly if you have any articles or youtube video that can help me?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,446 questions
Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
6,090 questions
Windows DHCP
Windows DHCP
Windows: A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.DHCP: Dynamic Host Configuration Protocol (DHCP). A communications protocol that lets network administrators manage centrally and automate the assignment of Internet Protocol (IP) addresses in an organization's network.
1,031 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Dave Patrick 426.3K Reputation points MVP
    2021-09-15T12:45:43.67+00:00

    Multi-homing a domain controller will always cause no end to grief for active directory DNS. You'll need to disable one of the adapters.

    --please don't forget to upvote and Accept as answer if the reply is helpful--

    1 person found this answer helpful.

  2. Limitless Technology 39,466 Reputation points
    2021-09-15T14:46:16.627+00:00

    Hello @Lavan.96

    Yes, this is a frequent issue. I would recommend 3 ways:

    • add the loopback adress as Host in the HOSTS file of the WDS server:
      \Windows\System32\drivers\etc\ to include "127.0.0.1 yourhostnamehere".
    • Change the binding of the services to the correct NIC:
      find the BindPolicy & BindInterfaces registry (HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WDSServer\Providers\WDSPXE)
      And set 0 for Excluding the NIC, 1 for Including
    • Enable just the need protocols on the 4G Interface Adapter:
      From the Properties of the adapter, disable one by one the protocols and services enabled. I would start for the one "Client for Microsoft Networks", then try.
      The main one to leave enabled is the TCP/IP v4, of course)

    Hope this helps in your case,
    Best regards,

    0 comments No comments