Container Instance stuck in "Pending" status

Stanislav Davydov 1 Reputation point
2021-09-15T15:07:11.487+00:00

I try to create Azure Container Instance from ARM template which I used previously.
Deployment says that instance is "Created" but when I go to that instance I see that it is in state "Pending" and for all containers there are no any events - so images was not even tried to be downloaded.

Same happens with other subscription and diferent region.
I do not see any problem with Azure Health Service - so wondering how I could see what is the problem with my deployments?

Update:
We are deployed ARM template through
https://portal.azure.com/#create/Microsoft.Template
using Custom deployment.
So it has nothing to do with k8s.

Update2:
Also it seams that MS has now issue https://app.azure.com/h/KKYB-RSZ/ but in description of that issue mentioned Service Buses and Storage account and NOT ACI

Update3:

There are no any init containers or volumes. I have tried to add Liveness check - but result is same with and without it.

$ az container attach --resource-group test --container-name moc --name ox_env  --subscription C  
Container 'moc' is in state 'Unknown'...  

And here are some screenshots from Portal:
133171-dbnectm3e1.png
133172-wg2igz8bvr.png
133116-kssebx9kxo.png
On second screenshot you could see "No events found in the last few hours" - that message was there all the time!

Azure Container Instances
Azure Container Instances
An Azure service that provides customers with a serverless container experience.
663 questions
{count} votes

1 answer

Sort by: Most helpful
  1. SUNOJ KUMAR YELURU 14,006 Reputation points MVP
    2021-09-15T15:52:39.357+00:00

    Hi @Stanislav Davydov

    Please check on the below url it is explained.

    When you deploy Pods to ACI through Kubernetes, you may recognize that all Pods stuck in state Pending when they’re meant to be deployed to the aci-connector node (aci-connector is the default name for the ACI node). You may ask why all pods stuck at this stage. To get more insights let us examine the cluster a bit
    https://www.thorsten-hans.com/fix-pods-stuck-in-pending-on-azure-container-instances/

    If the Answer is helpful, please click Accept Answer and up-vote, so that it can help others in the community looking for help on similar topics.