unable to print from pc connected to network - Worked fine on 15/9/2021- Operation failed with error 0x0000011b"

Firi 1 Reputation point
2021-09-16T11:10:36.323+00:00

Good day.

My point of sale system is running 3 pcs. The primary which has everything connected to it, which is also working fine. However, the 2 other pcs which are mapped to the primary are unable to print any longer from 2 of my printers, namely a zebra pd410 and a posiflex p9900. Everything worked fine up until close of business yesterday, and since we opened this morning, its just been a nighmare with us unable to do basic tasks as it cant print.

Kindly advise what is the next step as we have had our point of system techs from the company come out and check everything and all is fine from hardware side of things as well setup of the POS software. The issue lies with the update carried out yesterday.

Windows Server Printing
Windows Server Printing
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Printing: Printer centralized deployment and management, scan and fax resources management, and document services
649 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Alan Morris 1,161 Reputation points
    2021-09-16T15:10:36.747+00:00

    HI,

    There was a protocol change yesterday which requires both the server, the machine sharing the printer, and the client to be running the same protocol version.

    This will only affect a remote connection, the local printer which the server shares, can be printed to locally.

    I do not expect Windows 7 systems to get the patch with the new proper protocol version.

    I'll see if Microsoft has a work around.

    The Windows LPD service would be an alternative to a Windows to Windows connections but I will see I can wrangle a response regarding some workaround.

    0 comments No comments

  2. Limitless Technology 39,476 Reputation points
    2021-09-16T19:23:18.747+00:00

    Hello @Firi

    Most likely your machines have been updated overnight: there are three updates released recently that may provide this behavior: (KB5005613, KB5005627 and KB5005563). The reason is they are addressed to correct an explot vulnerability in printer driver injection (called PrintNightmare)

    Solution is to Create a GPO in the computer configuration:

    https://support.microsoft.com/en-us/topic/kb5005010-restricting-installation-of-new-printer-drivers-after-applying-the-july-6-2021-updates-31b91c02-05bc-4ada-a7ea-183b129578a7

    Or edit the registry lines:

    NoWarningNoElevationOnInstall = 1
    UpdatePromptSettings = 1
    RestrictDriverInstallationToAdministrators - 0

    Hope this helps with the issue,
    Best regards,

    0 comments No comments

  3. Firi 1 Reputation point
    2021-09-17T08:04:03.48+00:00

    Good day. I am currently busy updating all 3 machines once again with the latest updates. Ill revert back shortly

    0 comments No comments

  4. Firi 1 Reputation point
    2021-09-17T14:13:13.007+00:00

    So basically tried updating all the PCs which are conencted to network but we still in the same position. Only the main PC which has the printers connected to it via USB cables works fine. The others which are connected to the network cannot print.

    Needless to say this has brought about downtime in our business.

    0 comments No comments