Cannot configure dhcp options to indicate that this is also a pxe server

Ian Sha 1 Reputation point
2021-09-16T11:30:24.73+00:00

Hi,
i have some questions about this error right here.
i have a Wds and a DHCP in the same server. and i want to check these two boxes here below as shown in the image. (image:wds.png)
(Do not listen on DHCP ports)
(Configure DHCP options to indicate that this is also a PXE server)
Whenever i want to check the second box it says this error below. (wds2.png)
But as you can clearly see that my DHCP server are up and running. (wds3.png)
do i have to do something in the DHCP server it self or in WDS132743-wds3.png.
Very much appreciated.
(if my explanation is not clear enough please do not hesitate and ask :) )132695-wds.png132705-wds2.png

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,411 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,461 Reputation points
    2021-09-17T07:36:10.563+00:00

    Hello Ian S,

    Your explanation is more than enough, thank you for the detail! the issue here is that WDS and DHCP uses the same protocols and some default ports, meaning that are in conflict.

    Please refer to this thread for more information: https://social.technet.microsoft.com/Forums/windows/en-US/47cbd50a-0d1f-4f82-8bd3-dad4c6d6d1e9/wds-and-dhcp-in-same-server?forum=configmanagerosd

    In case you don't have other option, you will need to tune the system. DHCP and WDS both require port number 67. If you have co-hosted WDS and DHCP you can move DHCP or the PXE site role to a separate server or use the procedure below to configure the WDS server to listen on a different port.

    Modify the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WDSServer\Providers\WDSPXE

    Set the registry value to:

    UseDHCPPorts = 0

    For the new configuration to take effect run the following command on the co-located DHCP and WDS server:

    WDSUTIL /Set-Server /UseDHCPPorts:No /DHCPOption60:Yes

    This should allow them to coexist.

    Hope this resolves your question,
    Best regards!

    0 comments No comments