question

BenjaminCarleski-4605 avatar image
0 Votes"
BenjaminCarleski-4605 asked BenjaminCarleski-4605 answered

Unable to delete resource group

I have been trying to delete a resource group for almost a year now, with no success, and it just keeps sitting there sapping away at our available funds. Back when I first tried, there were 10 different resources in the group, and deleting the resource group deleted 7 of those, and then threw an error without any real detail, saying it couldn't delete the resource group. There are now the following three resources shown in the Portal site.

  1. Virtual Network

  2. Virtual Machine scale set

  3. Network security group

Every time I try to delete the resource group as a whole, it just fails. If I try to individually delete the resources, it won't let me. The NSG says it is being used by the VN. The VN says it is being used by one or more machines in the VMSS. The VMSS won't let me delete it because it says it has already been marked for deletion. The machines within the VMSS also won't let me delete them because the VMSS has been marked for deletion.

I have tried deleting resources both through the Portal interface, as well as through the resources.azure.com site. I'm not sure where else to go, or what else to do. Any help would be greatly appreciated.

azure-virtual-machines-scale-set
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@BenjaminCarleski-4605

Firstly, apologies for the delay in responding here and any inconvenience this issue may have caused.

As you have tried all possibilities from you side for deleting the resource group and still with no success. This issue needs deeper investigation to understand what is going wrong here.
Support team will be able to check and help on this. I would recommend you to open a azure support case.

If you don't have the ability to open a technical support ticket, please let me know I will help you further on this.

0 Votes 0 ·

Thanks for the response. I do not have a support plan, and even $29/month doesn't seem like a good choice when the issue is only costing me $3/month. Are there no other ways to get it deleted then?

0 Votes 0 ·

1 Answer

BenjaminCarleski-4605 avatar image
1 Vote"
BenjaminCarleski-4605 answered

I was able to open a ticket with the support team. After the issue was escalated a few times, I got the response below back. Maybe this will mean something to someone. Either way, after I got this response, I was able to go in and delete the resource group, and it actually removed it from my account.

Issue: Tenant is leaked in PPM , causing NRP to believe that the service is deleted but the SVI Manager(RNM) had not recieved delete call. This leads to subsequent getPendingDeleteResources call to fail causing the deletion to perpetually get stuck.
Mitigation: Added PPM entry and deleted the service. Customer can try to delete the RG again.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.