Remote desktop can't connect to the remote computer for one of the reasons

Panzera 6 Reputation points
2021-09-19T10:52:27.133+00:00

Hello all!
Hope you are well.

In my client's network, we have 3 windows 10 pro PCs. He used to connect to his PC in his office room from either of the other 2 in the building via remote desktop. That was until yesterday where the pc installed the kb5005565 update.

After the update, he went along with his day and tried to connect to the office PC but it returned the following message:

133299-screenshot-2021-09-19-134145.png

The strange thing is that he can control the other 2 PCs from his and the other 2 can connect fine with each other!

I tried and read everything (turn off the firewall, change the port for RDC, change the port to decimal, check services, policies, check hosts, check ping, check if it was allowed through the firewall, and more...) recommended as solution to no avail. I even unistalled the update but the problem persists.

I am literally one step from going crazy here. i can't find what is wrong all the sudden and i do not know what else to try so i can help him.

There is no file server or any server on the network. Roughly the network is composed by the isp router where 3 switches are connected (1 in each pc room), only having a PC and printer connected on them.

I would appreciate any assistance.

Thanks in advance.

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,399 questions
Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,312 questions
{count} vote

3 answers

Sort by: Most helpful
  1. Anonymous
    2021-09-19T12:28:21.913+00:00

    Try PowerShell from source and target. (use target address in both cases) post results

    Test-NetConnection -ComputerName "192.168.49.142" -CommonTCPPort "RDP" -InformationLevel "Detailed"


  2. Limitless Technology 39,511 Reputation points
    2021-09-20T10:22:50.097+00:00

    Hello,

    Thank you for your question.

    I would like to suggest you to check below Troubleshooting steps.

    1. If you think its due to KB5005565 then uninstall it to see if you are able to get back to RDP.
    2. Please try to run port query tool from Microsoft if the if you are able get thru RDP port
      https://www.microsoft.com/en-in/download/details.aspx?id=24009
    3. Please check if all three PCs are in same network and same subnet or try to give same IP range for all of them to narrow down the issue.
    4. Please cleanup C:\Windows\Temp and C:\WinNT\Temp

    If the reply was helpful, please don’t forget to upvote or accept as answer.


  3. cthivierge 4,056 Reputation points
    2021-09-21T15:14:48.593+00:00

    Can you validate on the destination computer that the value fDenyTsConnections is set to "0"

    reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fDenyTSConnections