WiFi Shows Wrong Time Zone and Wrong Country

Slad74 1 Reputation point
2021-09-20T15:00:01.597+00:00

Hello,

I recently updated my desktop with a new motherboard and cpu. The motherboard has built in WiFi, which I am using due to the location of the PC in my home. For some reason, when I set Windows to auto pick my time zone, it shows that I'm in China, which I am not. I am in central standard time (US), and I am not sure why this is happening. I have tried several options that I have found online, including entering my network mac address in the MS opt out location services website. Nothing works!

Also, when I log into my MS account on the MS website, it shows my PC is in Yueqing, Zhejiang...

This is very frustrating! Any thoughts or help with this will be appreciated!!

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,946 questions
Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,293 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. MotoX80 32,441 Reputation points
    2021-09-20T15:16:58.3+00:00

    Is your region set to US?

    133643-capture.jpg


  2. Reza-Ameri 16,846 Reputation points
    2021-09-20T16:47:28.277+00:00

    It might be a configuration in your router, check the DNS setting in the router and see if it is configured correctly.
    Check and make sure no VPN or Proxy has been setup in the router and you are not using in your PC.
    Check and see if you are facing the same issue if you connect with LAN?


  3. Limitless Technology 39,461 Reputation points
    2021-09-20T19:25:37.86+00:00

    Hello,

    Please try to login without Wifi and browse Internet using LAN connection and see what location it shows.

    Also try to login from different user profile on this computer.

    As you are in US time zone try to set from Control Panel -> Date and Time.

    Clean-up C:\Windows\Temp

    Hope this helps,

    0 comments No comments

  4. Slad74 1 Reputation point
    2021-09-22T02:21:49.403+00:00

    OK, I think I finally got this fixed. I updated the driver for the onboard WiFi on my motherboard, and, voila, it looks like it worked! I'm now seeing my correct time zone (and country) when I turn 'set time zone automatically' back on!

    Thanks for the help everyone!

    0 comments No comments