[SOLVED] Bad Request when trying to create new product in Azure Sphere (BadRequest)

AdamB-4111 346 Reputation points
2021-09-20T19:40:42.997+00:00

Hi Folks, I am getting an error when I am trying to create a new product for an azure sphere tenant.

I have a product called "Blinky" but I want to create another product which is code for a temperature/humidity sensor (SHT31).

However, when I try to create a new product in both the CLI and VS-Code I get the same "BadRequest" error.

What does the "BadRequest" response mean? I'm pretty sure I'm following the syntax requested.

Here is the attempt with the Azure Sphere CLI
133677-new-product-in-azsphere-bad-request.png

Here is the same attempt with VS Code

133648-vs-code-start.png
133678-vs-code-error.png

Azure Sphere
Azure Sphere
An Azure internet of things security solution including hardware, operating system, and cloud components.
163 questions
0 comments No comments
{count} votes

Accepted answer
  1. AdamB-4111 346 Reputation points
    2021-09-20T19:41:30.17+00:00

    I found the root cause!

    The name I was trying to use for the product "SHT31_Sensor" is not allowed.

    When I changed the name to "temp" it worked

    I am pretty sure the "_" underscore was the issue.

    2 people found this answer helpful.

0 additional answers

Sort by: Most helpful