IIS DONT RUN MY APP MAKET WITH .NETCORE 2.2

Néstor Valle Ruiz 41 Reputation points
2021-09-20T21:36:11.017+00:00

The Errors Catcheth in Event Viewer so this:

Faulting application name: dotnet.exe, version: 2.2.28209.1, time stamp: 0x5d9debb7
Faulting module name: KERNELBASE.dll, version: 10.0.14393.4350, time stamp: 0x606eb12a
Exception code: 0xe0434352
Fault offset: 0x000dc602
Faulting process id: 0x1ba8
Faulting application start time: 0x01d7ae651da63980
Faulting application path: C:\Program Files (x86)\dotnet\dotnet.exe
Faulting module path: C:\windows\System32\KERNELBASE.dll
Report Id: 9a210245-9237-4008-b5eb-432e94408ac9
Faulting package full name:

Faulting package-relative application ID:

Application: dotnet.exe
CoreCLR Version: 4.6.28207.3
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.FileNotFoundException: Could not load file or assembly 'System.Runtime, Version=4.2.2.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. The system cannot find the file specified.
at System.Reflection.RuntimeAssembly.GetType(RuntimeAssembly assembly, String name, Boolean throwOnError, Boolean ignoreCase, ObjectHandleOnStack type, ObjectHandleOnStack keepAlive)
at System.Reflection.RuntimeAssembly.GetType(String name, Boolean throwOnError, Boolean ignoreCase)
at System.Reflection.Assembly.GetType(String name, Boolean throwOnError)
at System.StartupHookProvider.CallStartupHook(String assemblyPath)
at System.StartupHookProvider.ProcessStartupHooks()


Fault bucket 1290766437059743833, type 5
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: C:\Program Files (x86)\dotnet\dotnet.exe
P2: 2.2.28209.1
P3: 5d9debb7
P4: System.Private.CoreLib
P5: 4.6.28207.3
P6: 5d9b871f
P7: 34e4
P8: 10
P9: System.IO.FileNotFoundException
P10:

Attached files:
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER49E3.tmp.WERInternalMetadata.xml
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_C__Program Files_e6f213c9be2ba1eaa044f93f835e2671a66a62c_732b538c_cab_090a49e2\memory.hdmp
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_C__Program Files_e6f213c9be2ba1eaa044f93f835e2671a66a62c_732b538c_cab_090a49e2\triagedump.dmp
WERGenerationLog.txt

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_C__Program Files_e6f213c9be2ba1eaa044f93f835e2671a66a62c_732b538c_0332915b

Analysis symbol:
Rechecking for solution: 0
Report Id: b71da82c-8ae3-49ca-ac80-7c62d1ab0eca
Report Status: 0


Application '/LM/W3SVC/49/ROOT' with physical root 'C:\inetpub\myApp\' failed to start process with commandline 'dotnet .\myApp.dll' at stage 'PostStartCheck', ErrorCode = '0x8027025b', assigned port 42558, retryCounter '1'.


I would appreciate any help, I don't know if I have to reinstall any component since the only thing my app needs is the .NetRuntime 2.2 to run in IIS but it still gives an error "HTTP Error 502.5 - ANCM Out-Of-Process Startup Failure" but On my main server, I already tried the application on other servers and if it was executed then I don't know what happens on my main server, what it needs or what it needs.

Internet Information Services
Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,455 questions
.NET Runtime
.NET Runtime
.NET: Microsoft Technologies based on the .NET software framework.Runtime: An environment required to run apps that aren't compiled to machine language.
1,136 questions
0 comments No comments
{count} votes

Accepted answer
  1. Limitless Technology 39,476 Reputation points
    2021-09-21T10:30:25.807+00:00

    Hello ,

    Thank for reaching out.

    1. Please try to create new IIS application and check what .net version configured in pool settings.
    2. Please try to give R/W permission to IISUsers for target folder mapped to IIS.
    3. From error logs its looks that I/O error and path not found , Please make sure path exists and they are registered using regsvr32.exe
    4. Please try to IISreset to clean the cache and sessions from IISpool.

    Hope this helps.

    0 comments No comments

3 additional answers

Sort by: Most helpful
  1. Néstor Valle Ruiz 41 Reputation points
    2021-09-21T14:31:20.2+00:00

    thank you very much but it is already trying,

    0 comments No comments

  2. Bruce (SqlWork.com) 59,471 Reputation points
    2021-09-21T15:25:51.027+00:00

    as .net core 2.2 is no longer supported (ended 12/23/2019), maybe an .net core update deleted the obsolete version. logon to the server and run

    dotnet --info

    to display the installed runtimes. see if the 2.2 runtime is installed, and matches the build box.

    your best bet would be to update to a supported version, but if you could also do a self contained deployment. This will include the build runtime in the deployment.

    0 comments No comments

  3. Néstor Valle Ruiz 41 Reputation points
    2021-09-21T16:11:41.493+00:00

    That's the strange thing, it only needs the .NETRuntime to run and I already have it installed in version 2.2.8, as I said before I tried it on a virtual server with virtual box and just installed the runtime and the published application and it already worked, but in my main server that is in azure is where I have the problem that it does not want to run, it throws this error when trying to start "HTTP Error 502.5 - ANCM Out-Of-Process Startup Failure

    Common solutions to this issue:
    • The application process failed to start
    • The application process started but then stopped
    • The application process started but failed to listen on the configured port

    Troubleshooting steps:
    • Check the system event log for error messages
    • Enable logging the application process' stdout messages
    • Attach a debugger to the application process and inspect

    For more information visit: https://go.microsoft.com/fwlink/?LinkID=808681 "

    0 comments No comments