DNS Cannot be recognized!

bill green 1 Reputation point
2021-09-21T00:25:55.037+00:00

I know I am in the wrong section, but I cannot find anyone to help. I figured a DBA could possibly help me with this issue.

I am getting this error from the command prompt whenever I ping :

"Ping request could not find host oraserver. Please check the name and try again."

My host file has been edited to add oraserver:

192.168.56.199 oraserver.myserver oraserver

I changed permissions and that sent me on this rabbit hole adventure.

Can anyone help? It appears administrator has a red "X" over it as if it is messed up.
133811-image.png

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,454 questions
{count} votes

3 answers

Sort by: Most helpful
  1. MotoX80 32,531 Reputation points
    2021-09-21T02:12:03.53+00:00

    Try using 2 entries. Does either name ping?

    192.168.56.199 oraserver.myserver  
    192.168.56.199 oraserver  
    

    Did you make the update with notepad or some other program? You might have changed the encoding. Open hosts with notepad and verify that it's UTF-8.

    133814-capture.jpg

    I changed permissions

    On what? The hosts file? Put it back. Hosts inherits all permissions from the Etc folder.

    0 comments No comments

  2. Limitless Technology 39,476 Reputation points
    2021-09-21T11:46:46.4+00:00

    Hello,

    Thank for reaching out.

    Please try to access your DB server using FQDN and see if you can get ping responses.

    Also, Please try to disable firewall and anti-virus for temporarily.

    In your host file also add another entry with ip and just hostname ( without FQDN).

    Hope this helps,

    0 comments No comments

  3. cthivierge 4,056 Reputation points
    2021-09-21T12:22:39.047+00:00

    I would go with @MotoX80 suggestion

    Try adding 2 lines in the hosts file. I had several issues with multiple name on the same line in the past that were fixed by adding separate line for each entry

    133938-hosts1.png

    0 comments No comments