SQL Server feature Database Engine Services failed to install

cece 116 Reputation points
2021-09-23T20:39:05.98+00:00

Hi,

So, I'm trying to install SQL Server 2019 Developer Edition (the Custom install) and I chose to install the features Database Engine Services, Analysis Services and Integration Services. Everything succeeded except for the Database Engine Services.

134738-error1.png

134776-error2.png

First the error code that I got was 1722, and because I'm very bad at reading logs, here are summary.txt and detail.txt regardind the error.

134778-summary.txt

134740-detail.txt

Tried to repair the issue with Maintenance from SQL Server Installation Center, also restarted Windows Installer from Services.msc and reregistered the Windows Installer with msiexec /unregister and msiexec /regserver commands.
After restarting the computer, I then tried to add the Database Engine Services feature to my previous installed environment. An error occured again. A different one this time, with the error code 0xe80004005.
134777-error3.png

134792-error4.png

You have summary.txt and detail.txt regarding this error too.

134821-summary.txt

134706-detail.txt

I tried to install SQL Server 2017 just to see if the error had to do with he version, but the result was the same.
I'm using a virtual machine running windows 11 (also tried with Win10 and the error are the same) with nothing else installed, so no previous SQL Server installations were made before this.
Can please, someone help me? Thank you.

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
13,336 questions
0 comments No comments
{count} vote

Accepted answer
  1. cece 116 Reputation points
    2021-09-30T15:53:49.123+00:00

    AmeliaGu-msft shared a Parallels forum thread with a solution that worked for me.

    Here is what I did:

    • I had to use Windows 10 Build 21376 (the one I had tried before was a different and more recent build, but couldn't get it to work).
    • Installed SQL Server. The Database Engine Services feature failed to install, but not to worry.
    • Downloaded and run Cumulative Update Package 12 for SQL Server 2019 - KB5004524.
    • Installed SQL Server again, this time just to add the missing feature in the same instance previously created.

    And that was it. The installation was a success!
    I could also install, without trouble, SQL Server Management Studio, Visual Studio and Power BI Desktop, and all seems to work perfectly.

    Thank you all for the help!

    2 people found this answer helpful.

2 additional answers

Sort by: Most helpful
  1. AmeliaGu-MSFT 13,971 Reputation points Microsoft Vendor
    2021-09-24T02:56:17.13+00:00

    Hi cece-5030,

    Welcome to Microsoft Q&A.
    Could you please try to download and install SQL Server again from official website? The installation package you are using may be corrupted.
    In addition, please remove previous failed installation clearly using the steps in this link.
    Please make sure you right click on setup.exe file and select run as administrator when you want to start the SQL Server installation. And disable any antivirus/security software and turn off firewall on the machine for the time that the installation is running.

    Best Regards,
    Amelia


    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Erland Sommarskog 106.6K Reputation points
    2021-09-24T20:55:27.85+00:00

    No, I don't think the account settings has anything to do with it.

    I looked at these logs last night, but I did not post anything, because I felt that I did not have that much useful to add.

    It seems like the problem is that a number of MSI files are missing, and I guess that's why Amelia thinks that the the download is corrupted. I am not sure that this is the case, but you could try the download from a computer, in case there is something that distorts the download.

    You say that you install a new VM each time, but I suppose that VM is installed from the same template?

    Am I right to assume that you are in a corporate environment?

    My hinch is that there is some anti-malware software active at your site that eats parts of the files the the install needs. But that is just a hinch, and I may be plain wrong.