Method not found: 'Microsoft.WindowsAzure.Storage.Blob.CloudBlobClient Microsoft.DataTransfer.Runtime.AzureBlobConnectorHelper.CreateBlobClient(System.Collections.Gene... Task failed: Azure Blob Download Task

medi_BI 1 Reputation point
2021-09-28T11:11:41.743+00:00

Hello all,

I'm working with Azure feature pack for SSIS and keep getting an error when trying to download files from azure blob storage. The error i keep getting is the following:

Error: 0x0 at Azure Blob Download Task, Azure Blob Download Task: Download task has stopped with exception: Method not found: 'Microsoft.WindowsAzure.Storage.Blob.CloudBlobClient Microsoft.DataTransfer.Runtime.AzureBlobConnectorHelper.CreateBlobClient(System.Collections.Generic.IDictionary`2<System.String,System.Object>)'.
Task failed: Azure Blob Download Task

It seems that it has something to do with versioning, but i dot really know what to do after re-installing everything.

Thanks!

Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
2,616 questions
SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
2,521 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Michael Taylor 51,341 Reputation points
    2021-09-28T15:12:32.817+00:00

    Did you enable TLS 1.2 in SQL Server as discussed in the installation instructions? I assume you are using the correct version of the Feature Pack for your version of SSIS but since this seems to be a call to Azure that is failing then that would be odd to me.

    I would also make sure you are using the latest version. The release notes are pretty sparse but it seems like an issue like you're mentioning would have been detected during testing.


  2. medi_BI 1 Reputation point
    2021-09-30T08:20:01.997+00:00

    @Michael Taylor thank you for your response.

    I have enabled TLS like it has been described in the installation instructions, but i'm still getting the same error.
    I'm using the next versions:

    Azure feature packs version 2019
    Microsoft SQL Server Standard 2019 (64-bit) Version: 15.0.2000.5.

    My VS version is: Microsoft Visual Studio Community 2019 Version 16.11.3.
    SSIS version 3.15

    I have tried everything i can think of but still not getting any progress on this.

    0 comments No comments

  3. EF Lin 1 Reputation point
    2022-04-14T00:21:24.587+00:00

    Hi, is there a solution to this please? Took me quite awhile to enable the TSL using IISCrypto tool... now the Upload task is working. But I will getting the same issue here for the download task...

    0 comments No comments