LarryBilodeau-9315 avatar image
2 Votes"
LarryBilodeau-9315 asked ClaasWunderlich-5992 commented

Unable to export a dataase from an Azure SQL Instance

The Azure SQL Database export function from the portal consistently fails with the following error:

An error occurred while communicating with the SQL Server using AdPassword-login: Could not discover a user realm.

I can provide an operation ID for the export job if that would help. I've found a workaround for this task using SSMS, but as far as I'm concerned the export function in the portal does not work at all.

· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I'm having the same issue, but exporting using the az cli. It's exactly the same error message.

1 Vote 1 ·

i have the same interest, i would like to use an AzAD Service Principal to perform this export. Is this supported?

1 Vote 1 ·

Hi @LarryBilodeau-9315, welcome to Microsoft Q&A forum and apologies for the inconvenience caused to you.

I tried using the Export on Azure SQL Database and was able to successfully export the Database to Storage account.

The error messages it looks like that the communication between Azure SQL Database and Active Directory user is failing. While connecting from SSMS, are you using the Active Directory Password Authentication or SQL Server Authentication?

0 Votes 0 ·

I am having the same issue @LarryBilodeau-9315 and @AnuragSharma-MSFT. I using AAD authentication with a service principal. I am aware that I cannot authenticate using a service principal to SMSS, but I should be able to the Sql database.

0 Votes 0 ·

seeing the same error using powershell New-AzSqlDatabaseExport

0 Votes 0 ·

0 Answers