convert a VMDK into a VHD ?

Ali 1 Reputation point

Is there any manual way to convert a VMDK to a VHD ?

I have tried all the tools Starwind, Winimage, disk2vhd etc they all generate a VHD file but when I create a ne Virtual Computer & attach the disk none works.

I get repeated errors "The virtual machine "New Virtual Machine" could not start because the hypervisor is not running"

I googled it & did enable DEP but that does not result in success.

In past i convrted a VHD to VMDK succesfully using the solution here

Is there a possibillity of converting the VMDK to VHD using an approach similar to the one in above mentioned article ?

Help would be appreciated. Thanks

A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,051 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Leon Laude 85,216 Reputation points

    Hi @Ali ,

    The above mentioned tools should all work for converting, I don't believe the problem is with the conversion tools but somewhere else, if you enabled your processor's virtualization technology in the BIOS and Hyper-V is still complaining about the "The virtual machine "New Virtual Machine" could not start because the hypervisor is not running" error then you could try uninstalling Hyper-V and then try reinstalling it completely.


    If the reply was helpful please don't forget to upvote and/or accept as answer, thank you!

    Best regards,

    0 comments No comments

  2. Limitless Technology 37,746 Reputation points


    Thank you for your question.

    All above tools are good and proven tools for this conversions.

    1. In your case Please try to create new Hyper-V VM and try to boot it .
    2. Please try to disable any Antivirus program for temporary purpose.
    3. In CMD
      bcdedit /set hypervisorlaunchtype auto -> reboot and try again

    --If the reply is helpful, please Upvote and Accept as answer--

    0 comments No comments

  3. Ali 1 Reputation point

    Reinstalling the Hypervisor lead to new errors in which it says

    boot failure. Reboot & select proper Boot Device ( proper devices are selected in Bios in Hyper V) , I did boot the disk into the cmd mode & then tried bootrec /fixmbr which worked but when I try bootrec/fixboot it says "access denied" , I did rebuild the MBR but still the same error that cannot boot from disk

    0 comments No comments