Guest Users not seeing Application on https://myapps.microsoft.com

John Guilbert 101 Reputation points
2021-09-29T10:14:24.447+00:00

Hi.

I have a flow that invites an external guest into a group. The guest user is created in AAD and added to this group. The group is used by an Enterprise Application called "JohnTest". I go to https://myapps.microsoft.com and login is guest user don't see Application appear. However, I add my member account and it pops up in https://myapps.microsoft.com after about 8 minutes.

Can anyone help. I have just added a license to the group and hoping this is problem.

Thanks.

John.

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,518 questions
0 comments No comments
{count} votes

Accepted answer
  1. John Guilbert 101 Reputation points
    2021-09-30T14:31:19.277+00:00

    Hi Marilee.

    Thank you for your prompt reply.

    After following your details I was getting no luck. Then by chance I decided to look at which tenant I was on by clicking on the user icon (top right) while in https://myapps.microsoft.com. I didn't realise the current tenant is located at the top left of this pop-up and was not the correct tenant. I clicked on "switch organisation" and found that this email address had been registered as a new guest on a number of tenants. So I selected the correct organisation in the drop down and hey presto. All good. This is something that would be very easy to miss so I am going to add the "tenant id" parameter to the link i.e. https://myapps.microsoft.com?tenantid=<tenant id>

    Thanks.

    John.

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Marilee Turscak-MSFT 36,336 Reputation points Microsoft Employee
    2021-09-29T23:04:24.493+00:00

    Make sure the user is assigned to the app and that the application is visible to users.

    1) Sign in to the Azure portal as the global administrator for your directory.

    2) Select Azure Active Directory.

    3) Select Enterprise applications.

    4) Select the application

    5) Select Properties

    6) For the "Visible to users" option, select "Yes" and click "Save."

    I would also recommend trying the steps from the troubleshooting guide:

    If an app was recently added, have the user sign out and back in again.

    If the app requires a license, such as Office, then make sure the user is assigned the appropriate license.

    Let me know if this helps.

    0 comments No comments