SSRS Portal not listening on Port 80

scott goodwin 1 Reputation point
2021-09-30T02:12:05.713+00:00

I have SQL Server 2016 running on Windows 2012 that has been working for several years. Two weeks ago we could no longer connect to it remotely from other servers though the portal continues to work locally. We have not installed any new software or made any significant changes to the server.

We found that if we changed the port from 80 to another (ex 999) things worked again. Unfortunately we cannot easily configure SSRS to use another port as we have a number of applications which are hard coded to connect to http://SERVERNAME/reportserver so we need to use the default port.

Any help we could get to have port 80 working again would be greatly appreciated.

SQL Server Reporting Services
SQL Server Reporting Services
A SQL Server technology that supports the creation, management, and delivery of both traditional, paper-oriented reports and interactive, web-based reports.
2,860 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Joyzhao-MSFT 15,571 Reputation points
    2021-09-30T06:03:53.69+00:00

    Hi @scott goodwin
    It may be related to the firewall.
    Reporting Services Report server applications and published reports are accessed through URLs that specify an IP address, port, and virtual directory. If Windows Firewall is turned on, the port that the report server is configured to use is most likely closed. Indications that a port might be closed are receiving a blank page when you attempt to open the web portal from a remote client computer, or a blank Web page after requesting a report.

    To open a port, you must use the Windows Firewall utility on the report server computer. Reporting Services will not open ports for you; you must perform this step manually.

    For more information,please refer to: Opening Ports in Windows Firewall (To open port 80).

    If the above does not work, please try to pen an elevated command prompt and type: netsh http show urlacl

    This should give a list of all registered URL’s on the system.

    Deleting the reserved URL's for Reporting services running netsh http delete urlacl=https://ServerName/ReportServer and going back through reporting services configuration tool and configuring SSL again, Reporting Services started listening over SSL.

    For more information,please refer to:
    https://social.msdn.microsoft.com/Forums/en-US/ae61bc89-bab4-4a45-834d-4940a7bfed09/reporting-services-stopped-listening-on-port-80-or-port-443?forum=sqlreportingservices
    https://vosseburchttechblog.azurewebsites.net/index.php/2013/11/28/what-to-do-when-ssrs-2012-is-not-happy-with-port-443-or-80/

    Best Regards,
    Joy


    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments