Litetouch deployment failed "Failed to create shared environment"

corne nietnodig 196 Reputation points
2021-10-01T17:48:42.867+00:00

Deploying an image with MDT2013 to clients, made a new Task sequence with the newest Windows 10 21H1. In this tasksequence i have put several install msi's beneath the sate restore option.
Deploying this Image gives at the end of the deployment 5 errors. The image is deployed with those 5 errors but Windows is installed. The only problem is that the applications are not installed none of them.

I am looking in what stage of the Task sequence it goes wrong, it must be for the install applications in the sate restore starts because the applications are not starting.

These are some text from the log files bdd and smsts.log:

Litetouch deployment failed, Return Code = -2147024891 0x80070005]LOG]!><time="15:49:18.000+000" date="10-01-2021" component="LiteTouch" context="" type="3" thread="" file="LiteTouch">
<![LOG[Event 41014 sent: Litetouch deployment failed, Return Code = -2147024891 0x80070005]LOG]!><time="15:49:18.000+000" date="10-01-2021" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
<![LOG[For more information, consult the task sequencer log ...\SMSTS.LOG.]LOG]!><time="15:49:18.000+000" date="10-01-2021" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">

smsts.log
<![LOG[Running Task Sequence in standalone.]LOG]!><time="15:49:18.359-120" date="10-01-2021" component="TSMBootstrap" context="" type="0" thread="3192" file="tsmbootstrap.cpp:554">
<![LOG[Failed to create shared environment)]LOG]!><time="15:49:18.359-120" date="10-01-2021" component="TSMBootstrap" context="" type="3" thread="3192" file="environmentscope.cpp:573">
<![LOG[Failed to create the Shared Environment object. Code(0x80070005)]LOG]!><time="15:49:18.359-120" date="10-01-2021" component="TSMBootstrap" context="" type="3" thread="3192" file="tsmbootstrap.cpp:561">
<![LOG[Failed to run task sequence (0x80070005).]LOG]!><time="15:49:18.359-120" date="10-01-2021" component="TSMBootstrap" context="" type="3" thread="3192" file="tsmbootstrap.cpp:736">
<![LOG[Failed to run task sequence]LOG]!><time="15:49:18.359-120" date="10-01-2021" component="TSMBootstrap" context="" type="3" thread="3192" file="tsmbootstrap.cpp:970">
<![LOG[Exiting with return code 0x80070005]LOG]!><time="15:49:18.359-120" date="10-01-2021" component="TSMBootstrap" context="" type="1" thread="3192" file="tsmbootstrap.cpp:1303">

Someone an idea what goes wrong here?

Microsoft Deployment Toolkit
Microsoft Deployment Toolkit
A collection of Microsoft tools and documentation for automating desktop and server deployment. Previously known as Microsoft Solution Accelerator for Business Desktop Deployment (BDD).
852 questions
0 comments No comments
{count} votes

Accepted answer
  1. AllenLiu-MSFT 42,746 Reputation points Microsoft Vendor
    2021-10-04T06:15:46.467+00:00

    Hi, @corne nietnodig
    Thank you for posting in Microsoft Q&A forum.

    You may try not to join the PC to the domain to see if it helps, it seems the issue is OU related, you may refer to below links for more details:
    https://social.technet.microsoft.com/Forums/en-US/e65b3300-5dd6-41a7-8280-9242c1573c59/failed-to-create-shared-environment-when-deploying-w10-v1703-via-mdt?forum=mdt
    https://social.technet.microsoft.com/Forums/en-US/88807c0c-f78b-40bb-9972-024d992dc863/mdt-failed-to-create-shared-environment?forum=mdt


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. corne nietnodig 196 Reputation points
    2021-10-04T09:34:07.563+00:00

    I think i have found it. In the customsettings.ini i had changed some time ago the domain join user. I think this user has the rights to join pc to the domain but also think that this is the problem.

    I will test this tomorrow..

    0 comments No comments