Replication Monitor not working

tobz 161 Reputation points
2021-10-01T20:36:18.02+00:00

Hi everyone,

I recently noticed that replication monitor is not working properly. Whenever I try to launch it, the icon shows in the Taskbar of my indows but the application never actually open.

Anyone with similar issue, please advise

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
13,343 questions
{count} votes

5 answers

Sort by: Most helpful
  1. Shavil Dasrath 16 Reputation points
    2022-10-31T07:40:19.657+00:00

    Open the replication monitor window, this should be opened on the taskbar, hold down shift key, right click and maximize then the replication monitor window should open up

    3 people found this answer helpful.
    0 comments No comments

  2. CathyJi-MSFT 21,126 Reputation points Microsoft Vendor
    2021-10-04T02:43:36.553+00:00

    Hi @tobz ,

    What is your SSMS version? Suggest you using the latest version SSMS 18.9.2.

    The SSMS 18.x installation doesn't upgrade or replace SSMS versions 17.x or earlier. SSMS 18.x installs side by side with previous versions, so both versions are available for use. However, if you have a preview version of SSMS 18.x installed, you must uninstall it before installing SSMS 18.9.2. You can see if you have the preview version by going to the Help > About window.

    If it is still not work, please share us a screenshot about your issue.


    If the response is helpful, please click "Accept Answer" and upvote it, as this could help other community members looking for similar thread.

    2 people found this answer helpful.

  3. Kobus Vermeulen 6 Reputation points
    2022-07-15T10:27:48.17+00:00

    I have the same issue in SSMS 18.12.1, have had it for a while, but difficult to say when it started happening. From at least 18.11 though. Problem is exactly as described, the Replication Monitor opens in the taskbar, but is inaccessible and never displays anything. Clicking on the icon does nothing. Trying to tab to it shows a blank screen in the preview (like DerekMeyer's screenshot), but once selected doesn't open anyway. I run Windows 11, not sure if that makes a difference. It's incredibly annoying though.

    1 person found this answer helpful.

  4. Shawn Joyce 5 Reputation points
    2023-01-31T16:53:16+00:00

    Upgrading to SSMS 19x resolved the problem for me. It was working previously for version 18.x under windows 10, my company upgraded my laptop to win 11 and this one feature no longer worked (not something I need often so took a while to notice it never opened the window when run).

    1 person found this answer helpful.
    0 comments No comments

  5. Derek Meyer 1 Reputation point
    2022-06-14T23:05:44.347+00:00

    I am also experiencing this issue. The icon shows on my Taskbar. I am currently using versions 18.11.1 as well as 17.9.1 (as a backup) and it appears to occur in both versions.

    211388-image.png

    0 comments No comments