IIS 10 ISAPI DLL giving 404.0 error on dll file after enabling it

Wouter3D 1 Reputation point
2021-10-04T07:53:30.877+00:00

I've been working with isapi.dll files on IIS for years, up to IIS 7.0.

I am now trying to migrate my Server 2008R2 to Server 2019. I have done everything I know, but nothing seems to work.

Here is what I've done:

  1. Made sure the server Roles & Features for the Web Server includes CGI, ISAPI Extensions, and ISAPI Filters. I've even removed and re-added all these features to make sure there wasn't a problem when first installing them.
  2. On IIS Manager, on the default site, I added a new application (scripts) and made sure the dll file with all supporting files are in this folder (exactly the files that work on IIS 7.0).
  3. If you open the dll file in a browser, it tries to download the file, which means my IIS server works, the application folder alias works, and IIS found the dll file.
  4. On the application folder's Handler Mapping, I enabled CGI and ISAPI.dll by ticking Execute on Edit Feature Permissions.
  5. If you open the dll on the server browser now, you receive a 404.2 error, stating that you have not added the dll to the CGI and ISAPI Restrictions List, which means it is recognizing that the dll file as an ISAPI dll file.
  6. In IIS Manager, on the server tab on the left, opening the CGI and ISAPI Restriction feature, added the dll file and made sure to Allow access. I also tried to update the Feature Settings to enable all unspecified DLL and CGI files, just to cover all bases.
  7. Now, if you open the dll in the browser you should see some results (even if it is an error 500 if some supporting files or database connections don't work), but instead I get a 404.0 error that the file is missing or moved.

I have tried every possible combination of all the suggestions on the web, but effectively all of them come back to the steps above.

Any assistance to point me in the right direction will be helpful.

Internet Information Services
{count} votes