blue screen of death using microsoft edge

Erin 41 Reputation points
2021-10-04T16:06:27.313+00:00

I have been using the pdf editor function of the microsoft edge to take notes using my Microsoft surface go. I received a blue screen of death saying "resource not owned" or an automatic restart (the former is more frequent) after microsoft edge is opened for a few minutes. Windows 10 install a new updates yesterday but I have already encountered the problem once before the update, and the problem consistently happens after installing the new update. I tried the compatibility mode, which makes the blue screen appear a little later after I open the microsoft edge. I tried SFC scan and re-installation but it does not solve my problem.

Windows for business | Windows Client for IT Pros | User experience | Other
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  1. Completely Normal 16 Reputation points
    2021-10-05T06:07:27.973+00:00

    Cause:
    This seems to be an issue tied directly to the most recent version of Edge (Ver. 94.0.992.38). The crashes are affecting Edge users, but also users of apps that integrate Edge functionality; specifically, the use of a stylus or pen is the factor that seems to be causing the problems. Edge itself currently offers pen functionality with the writing/notes feature; and many of us here are reporting issues with Surface type devices (I would assume also, Surface Pens), so this information seems to track with what we already know.

    Reference:
    The article linked below came from CELSYS (a software development company known for their illustration/animation title, 'Clip Studio Paint'). By way of brief summary, it states that:
    * The blue-screens are due to a problem with Microsoft Edge (Ver. 94.0.992.38), released 1 October 2021;
    * Using of a pen/stylus will cause the crashes/locks, while using a mouse will not; and
    * The issue has been reported to Microsoft and is currently awaiting a fix to be resolved.

    Source: https://support.clip-studio.com/en-us/faq/articles/20210120

    Answer:
    So while we await a fix from Microsoft, the immediate (and hopefully temporary) solutions to this issue will be either:

    • Use a different browser and/or software for your note taking; or
    • Use Edge without a pen or stylus (ie. mouse only)
    1 person found this answer helpful.
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  2. Reza-Ameri 17,341 Reputation points Volunteer Moderator
    2021-10-04T17:31:22.657+00:00

    Run Windows Update and install all updates.
    Try run the Microsoft Edge in InPrivate Browsing mode (Ctrl+Shift+N) and see if the problem persist?
    In case you have any extensions try disable them.


  3. jared pratt 1 Reputation point
    2021-10-05T02:17:35.117+00:00

    Same issue, surface go restarted and updated in the middle of work, not only was that annoying but now it blue screens every 30 minutes or so.

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  4. Limitless Technology 39,931 Reputation points
    2021-10-05T08:53:50.85+00:00

    Hello,

    try to disable Windows Ink.

    Open Registry Editor.
    Go to the following Registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsInkWorkspace. ...
    Create a 32-bit DWORD value named AllowWindowsInkWorkspace. ...
    Sign out and sign in back to your Windows account

    Also install all updates pending.


    --If the reply is helpful, please Upvote and Accept as answer--


  5. Ariel Machado 16 Reputation points
    2021-10-06T09:07:34.77+00:00

    The Microsoft Edge team is aware of this issue that affects last release of Edge when using a pen:

    "Hey folks!
    The team is aware of this and investigating, I'll circle back here with any updates or if we need additional information to dig in. Thank you so much for your reports of this, both here and in the browser itself!
    Alex Rowell (she/her)
    Community Manager - Microsoft Edge"
    Source:
    https://techcommunity.microsoft.com/t5/discussions/bsod-with-message-resource-not-owned-when-using-pen/m-p/2814304/highlight/true#M50034

    "Wanted to first note that yes, we are aware of using a pen on Windows 10 in Edge is "blue screening" devices. The team has been actively digging into this and I hope to have more details very shortly. I will edit this post once I hear from the team on next steps for those of you hitting this."
    Source:
    https://www.reddit.com/r/edge/comments/q268a5/dev_channel_update_to_version_96010320_is_going/

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