Azure Function with blob trigger not functionning unless I go on the portal

Benoit Thiboutot 1 Reputation point
2021-10-04T16:59:19.767+00:00

Hi,

I have an Azure Function based on a blob trigger.
Simple C# application converting an Excel file to a CSV one. Pushes back to the same storage account.
Seemed to be working fine for a while, but not it doesn't seem to run automatically. I have to go on the portal itself to see it kick in.

I've noticed that there seems to be a lot discussions around this on the Web, but I couldn't find any fix.

I'm requesting some help get it back to working automatically.

Thank you,
Benoit Thiboutot

Azure Functions
Azure Functions
An Azure service that provides an event-driven serverless compute platform.
4,630 questions
Azure Storage Accounts
Azure Storage Accounts
Globally unique resources that provide access to data management services and serve as the parent namespace for the services.
2,906 questions
Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
2,612 questions
{count} votes

2 answers

Sort by: Most helpful
  1. David Andrews 26 Reputation points
    2022-03-11T21:02:26.897+00:00

    Hi @MayankBargali-MSFT were you able to resolve this issue. I am facing the same problem with a blobtrigger that originally automatically picked up a file but now only works if I manually call the trigger from the azure portal. I have other triggers on the same function app that work fine.

    0 comments No comments

  2. Benoit Thiboutot 1 Reputation point
    2022-03-14T12:24:13.307+00:00

    Hi David,

    Found the issue after quite some time with Functions and Storage Account teams.

    For some reason, logs were not being created anymore for some time and then they just restarted by themselves.
    I suspect an update on the Azure part was responsible for the issue both times (stopping and restarting them), but we never got to it.

    Look into "Diagnostic Settings (classic)" and turn on logs if they have been turned off.

    Thank you,
    Benoit Thiboutot