question

HaroonMasroor-3905 avatar image
0 Votes"
HaroonMasroor-3905 asked CaseyYangMSFT-4714 commented

Login Box Appears in anonymous view


Dear concern,

I am a (Full control access) user on a specific Sharepoint link. I am using Html Code, and to display that on smart phones, I have disabled mobile view. Also have set my access for anonymous public use on that link,

and I am getting login box message in mobile or smart devices but on Desktop Computer, it is not showing the login box(despite the Main Administrator told me they have settings level same for mobile and desktop view).

PS: I don't want login box to appear in both.

What could be the reason that its behaving differently on different platforms while the settings are same.

Thanks and Reagards

HaroonM

office-sharepoint-server-administration
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

CaseyYangMSFT-4714 avatar image
0 Votes"
CaseyYangMSFT-4714 answered CaseyYangMSFT-4714 commented

Hi @HaroonMasroor-3905,

Are you using SharePoint Online?

You could try to sign out your account then clear your browsing data and login again.

After you login, in stay signed in page remember to select "Yes". Then next time you login this site there will be no login box.

137971-1.png


If an Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



1.png (24.2 KiB)
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

thank you for your feedback. but this is not my problem. I am using anonymous access (for public use) and in general it does not require me to login and then view the Sharepoint portal.

let me elaborate plz, when i open portal on mobile a msg box appears asking me to login(under anonymous settings) canceling it simply takes me to the web portal accessible. But on my laptop/desktop that msg box wont pop up. it directly landed up on the web portal without asking to login. My only problem is that msg box for mobile users. that do should not appear for anonymous users in any case and on any device.... and asking for its solution. I hope i am now able to explain my problem better.

Thank you

0 Votes 0 ·

Hi @HaroonMasroor-3905,

Sorry for my late response, if you are using SharePoint server please make sure you enabled "Anonymous Authentication" in IIS. And make sure you selected "None – No Policy" in Central Administration Anonymous Policy.

For Reference: Getting Login Prompt on Anonymous Access Enabled SharePoint Sites
Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


0 Votes 0 ·