I cant turn on my secure boot

Bui Thanh Cong 1 Reputation point

ive some trouble with my secure boot ( greyed out secure boot) that i cant change to active or enable
i already tried some method but my BIOS doesnt have "Supervisor password" so what should i do

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,896 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Limitless Technology 39,506 Reputation points

    Hi there,

    If Windows 10 was installed in Legacy BIOS mode, then your hard drive has a partition style of MBR, if you change to UEFI, then that only works with a partition style of GPT. Back up all your personal files, then clean install Windows 10 from a bootable USB in UEFI Mode and then enable TPM and check if you can enable the secure boot.

    If the PC does not allow you to enable Secure Boot, try resetting the BIOS back to the factory settings

    If the reply is helpful, please Upvote and Accept it as an answer

  2. Kapil Arya 7,856 Reputation points MVP

    Try updating BIOS, see if that helps!

  3. Mr Sb 356 Reputation points

    If a supervisor password is set, and you don't know the password, contact the owner of the device. You must have this password in order to enable secure boot in the BIOS.

  4. Bui Thanh Cong 1 Reputation point