Mac Microsoft Remote Desktop App 10- Remote Feed issue no workspace is associated with this url

seth bestulic 96 Reputation points
2020-08-03T20:20:51.067+00:00

I have recently setup a RDS implementation on Server 2019, an upgrade over my old Server 2012 R2 RDS setup, it works perfectly for windows systems using the Web Access Portal (the IIS web page).

Mac users though have to use the Microsoft Remote Desktop App. This used to work fine in the Server 2012 R2 RDS environment with this behavior-
Remote feed setup for Microsoft Remote Desktop 8 - https://remote.domainhere.org/rdweb/feed/webfeed.aspx
Remote feed setup for Microsoft Remote Desktop 10 - https://remote.domainhere.org

Now on 2019 Microsoft Remote Desktop 8 will not connect at all, and some users get in fine with 10 using the address mentioned (https://remote.domainhere.org)... but a bunch of users when entering this string get this error: no workspace is associated with this url

If I configure a gateway pointing to our gateway address and a PC behind the gateway they can connect using the "PC" tab just fine, and if they go through Chrome to the Web Access Portal and download an RDP file for a connection to any Session Host those RDP files can be loaded into the Microsoft Remote Desktop app without issue...

I've had users uninstall the app, delete all the library settings for it, restart, reinstall the app and still no behavior change occurs.

Some possibly relevant information: This seems to be users who first loaded RDP files from Chrome before trying to configure the connection string for the Workspace (But I haven't confirmed that this is the case for all of these users)

If I edit the saved connection information loaded from one of these Chrome downloaded RDP files, either in the RDP file or in the Microsoft Remote Desktop app the app ignores the changes and connects to whatever the RDP file originally specified (really weird, it's like it's saving this info somewhere the user can't see and manual edits are not taking effect.

I've tried disabling the firewall in MacOS for these users (but they were all able to connect to the old environment fine and can connect directly to systems as described above so this doesn't sound like a firewall issue to me)

The RDS Environment is configured to use the Azure AD Application Proxy (in passthrough mode, since pre-auth isn't compatible with the Microsoft Remote Desktop App).

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
3,034 questions
{count} votes

7 answers

Sort by: Most helpful
  1. 2020-08-04T05:36:54.063+00:00
    No comments

  2. seth bestulic 96 Reputation points
    2020-08-05T23:43:50.233+00:00

    Hi PhoebeLu,

    I saw that when searching around but ignored it since I'm not going through any WAPs... but I figured I'd check anyways since you brought it up...

    I have no updates installed, I haven't patched these systems. Doing so now. I don't expect it to resolve the issue but will report back.

    No comments

  3. seth bestulic 96 Reputation points
    2020-08-10T18:27:51.827+00:00

    I updated my Connection broker/gateway server and my hosts and had one of the affected users test. There is no change in behavior. This is impacting ~4-5 out of around 30 apple users out of our total of 120 RDS users. We had no problem with this in Microsoft Remote Desktop version 8.

    No comments

  4. seth bestulic 96 Reputation points
    2020-08-10T23:02:29.497+00:00

    Some further complications-
    My setup uses the Azure AD Application Proxy in passthrough mode (pre-authentication is not supported at all in the Mac Microsoft Remote Desktop App).

    Created a record that bipasses the Azure AD Application Proxy, and just punches right into our network. Using this address... the problematic devices connect without issue. This is interesting since MANY users are connecting using this app just fine through the proxy, it's just a random sampling who aren't.

    I have no intention of keeping a non-proxied route open into my organization's network, there's got to be a fix for this.

    No comments

  5. seth bestulic 96 Reputation points
    2020-08-24T16:43:53.643+00:00

    Hi PhoebeLu,
    Please see my responses to your last list of suggestions. Currently I'm still having this issue and have identified more users experiencing it.
    Thanks.